Results 1 to 10 of 18

Thread: HP elitebook 8530w w/ FireGL 5700 "Ubuntu Compatibility"

Threaded View

  1. #1
    Join Date
    Mar 2008
    Location
    Hawaii
    Beans
    806
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    HP elitebook 8530w w/ FireGL 5700 "Ubuntu Compatibility" "How To"

    Aloha
    by, HunterThomson - HowTo's that WORK !

    The Open Source ATI driver xf86-video-ati is a far better driver then the Catalyst. However, it has poor power saving support, so could run hotter. Also, has poor 3D support but can play Quake Live, Tribal Trouble 2, Super Tux Kart, Open Arena. However, EVERYTHING ells is SUPER. KVM 2D, Video, All that is really good.

    However, I am happy to say we got EVERYTHING working on this laptop. Well all but the fingerprint reader but from what I understand there just is not a Linux driver for the "AuthenTec with 08ff:2810"

    This thread will provide you with all the info I have on getting the HP EliteBook 8530w w/ ATI FireGL 5700 to work with Ubuntu Linux. Feel free to post any new info you have. We would all be vary happy to hear what you have to say.


    First things First, in order to avoid a Kernel panic Enter the CMOS set-up and change the option,
    Code:
    "Fan always on while on AC" to "OFF"
    Big Thanks to DanaG He is the one that found the fix for...
    Getting the Catalyst to work with the acpi services off thing
    Booting with EFI/UEFI
    Fixing the accelerometer
    Blacklisting the driver that sees the accelerometer as a joy stick
    Provided the xorg.conf file I use and posted to this thread

    eSATA port >>>>> Works I have and external HHD plug in it right now
    Compiz >>>>> Works With patched Xserver see HowTo below
    BlueTooth >>>>> Works
    Cardreader >>>>> Works well I have a SDHC card and it works...
    Express card >>>>> Works
    SmartCard >>>>> Works From what I am told
    Dule Head >>>>> Works You just need to set up the xorg.conf file
    Optical Drive >>>>> Works
    Audio >>>>> Works Out of the Box
    Fingerprint >>>>> Nope I think it mite work VirtualBox has an entry for it? OpenBSD sees it too
    TrackPoint >>>>> Works
    Tuchpad >>>>> Works
    Volume Slider LED>>>>> Works
    Mute LED >>>>> Works
    Fn backlight >>>>> Works Even the auto sensor
    Suspend >>>>> Works
    Hibernate >>>>> Works
    Intel WiFi 5300 >>>>> Works You will need to follow the "How To" below
    Ethernet >>>>> Works
    FireGL 5700 >>>>> Works With tweaking only, only Ubuntu
    Docking Station>>>>> Works USB,DVI,VGA,LAN,PS2,Serial,Audio Out work>>>Parallel port & Audio In untested
    3G HPun2400 >>>>> WorksI'll write instructions latter but for now just Google... HPun2400 ubuntu ...and you will find how to use it


    Ok so, now that we got that out of the way. Here are a few things I found out.

    1. ATI Mobility FireGL 5700 is not fully supported by the Open Source AIT driver yet so you have to use the Catalyst.

    2. Track point falls off real easy. If I were you I'd pull it off now and put a small, vary small amount of glue on it and stick it back on. I used a pin head dot of JB weld (I like the JB weld I suggest it and it is good to have around the house anyway so go buy some) in the rubber button it self not on the keyboard stub(I really used a Pin). Use vary little glue. If any glue squeezes down into the keyboard that would be vary bad. However, you can replace the keyboard vary easyly. First unscrew the two screws on the bottom of the laptop with the picture of a keyboard next to them. Then, you see thoughts four tabs in between the F1-12 keys... you just slide them back away form the screen and the whole keyboard will pop right out.

    3. I found a fix for the Intel WiFi 5300 and wrote up a HowTo below. The intel 5300 driver is vary buggy with the current 2.6.28-11 Kernel in Jaunty 9.04. It would cause corruption of downloads and rendered the WiFi useless.

    4. The Linux Kernel will crash if you don't change a BIOS setting. You have to go into CMOS set-up and change the "Fan always on wile on AC" to "Off."

    5. The BIOS would not see my OCZ Vertex SSD drive if I had even One Logical partition. I don't know if this is a problem with other HHD's SSD's but if your laptop is not booting. Make all the partitions Primary Partitions.

    6. The Mobility FireGL 5700 is really a Radeon HD3650.

    7. WOW dose this thing run cool. I am downloading a torrent and surfing the web and my CPU (P8400) is at 25C !

    I got the Catalyst to work in Archlinux

    I would like to say....

    The WiFi is no problem in Arch linux
    Flash is no problem in Arch linux
    Video games like supertuxkart in the menu screen thinking that your pressing joydown all the time... Is not a problem in Archlinux
    -------------------------------------------------------------------------------------------------------------

    How to get the Intel WiFi 5300 Working in Ubuntu 9.04

    OK, you will need to install the new Pre-released Kernel and backports
    I think that it is really just the new Ubuntu Kernel that is fixed. So, when we officially are on Ubuntu Kernel 2.6.28-12 then you probably will not need to do this.


    >OK Before you mess with the Catalyst install you need to upgrade the Kernel so your work will not be in vain.

    >If you have already installed the Catalyst and are now Fixing the WiFi...
    > Just Follow this HowTo "word for word" but this will brake your Catalyst Driver. So, You will need to follow the section I have below "This is What you Will do to Fix It"


    >You will need to enable Ubuntu Pre-released updates by first opening the "Software Sources" GUI here...

    Code:
    System/Administration/Software Sources
    >Now click on the "Updates" Tab and check the box to the left of "Pre-released updates (jaunty-proposed)"

    >Then click close and it will up date the package list.

    >Now open a terminal and install the linux-backports-modules-jaunty

    Code:
    sudo apt-get update && sudo apt-get install linux-backports-modules-jaunty
    >Now DON'T Reboot

    >Install the Kernel headers for this new Kernel because you will need them latter.

    Code:
    sudo apt-get install linux-headers-2.6.28-12-generic
    >Ok all done really just go back into the "Software Sources" and Un-check that box next to the "Pre-released updates (jaunty-proposed)"

    >Then click "close" and it will update the package list agin.

    -------------------------------------------------------------------------------------------------------------

    To install the ATI catalyst Follow these steps.

    I got most of this stuff but not all form this thread and it "mite" be of use to you if you have some question or problem latter on.
    http://wiki.cchtml.com/index.php/Ubu...allation_Guide

    1- Download the newest driver from the ATI web site.

    http://support.amd.com/us/gpudownload/Pages/index.aspx

    >Select Linux x86 or x86_64 -> Then radeon -> Then HD3xxxx

    >If you like you can install this stuff but Ubuntu will install it automatically

    Code:
    sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf libstdc++5 dkms
    >Then open the terminal and change directory (cd) to where you downloaded the catalyst driver.
    Like this if you downloaded it to the Desktop.


    Code:
    cd Desktop
    >Then create .deb packages out of the installer. Note the checksum will be off if you downloaded it while on the Intel 5300 wireless card because the download really is corrupted. You will have to be on Ethernet or use a USB wireless card.

    Code:
    sh ati-driver-installer-9-*-x86.x86_64.run --buildpkg Ubuntu/jaunty
    >Then run this command and it will error out. That is OK.

    Code:
    sudo dpkg -i xorg-driver-fglrx_*.deb fglrx-kernel-source_*.deb fglrx-amdcccle_*.deb
    >Then install the --force command.

    Code:
    sudo apt-get install -f
    >Now the installer will work.

    Code:
    sudo dpkg -i --force-overwrite xorg-driver-fglrx_*.deb fglrx-kernel-source_*.deb fglrx-amdcccle_*.deb
    >Now you need to download the working xorg.conf.txt file attached to this thread. "Save To your Desktop"

    >Now run this command to backup your cerent xorg.conf and install the working one you downloaded to the Desktop.

    Code:
    sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf-bkp && sudo mv ~/Desktop/xorg.conf.txt /etc/X11/xorg.conf
    >Now you have to turn off ACPI support for your ATI grafics card to avoide a Kernel Panic

    Code:
    sudo aticonfig --acpi-services=off
    >Now reboot and all "Should" be well and working.
    -------------------------------------------------------------------------------------------------------------
    OK now to make Compiz play nice with Xorg Sever

    Ok, I got all of this form this link. So look here if this is out of date or not working

    https://edge.launchpad.net/~ubuntu-x...er-no-backfill


    >Ok so you need to add a new source to your repo's

    >Fist open the "Software Sources" GUI

    Code:
    System/Administration/Software Sources
    >Then select the tab "Third-Party Software

    >Then Add... these two APT lines by clicking on the "Add..." button and cut/past them in. Add them "ONE at a Time"

    Code:
    deb http://ppa.launchpad.net/ubuntu-x-swat/xserver-no-backfill/ubuntu jaunty main
    deb-src http://ppa.launchpad.net/ubuntu-x-swat/xserver-no-backfill/ubuntu jaunty main
    >OK good stuff, Now you just need to enter it's GPG Key

    >Fist follow this link

    http://keyserver.ubuntu.com:11371/pk...CDFA9&op=index

    >That "Should" open a new tab, On that tab you will see

    Code:
    pub  1024R/AF1CDFA9 2009-01-20 Launchpad PPA for Ubuntu-X
    >Click the "AF1CDFA9" or whatever that # is at the time.

    >Then it should take you to a page with the GPG/PGP key and looks like this

    Code:
    -----BEGIN PGP PUBLIC KEY BLOCK-----
    Version: SKS 1.0.10
    
    mI0ESXVCiwEEANKBDbiSLOJOouub/S97iDifYCVW1b0KONg7XkFYiFos+bMBzzZyGGo90k1h
    hCxcseLvqCKPL7dG0RzPRKMo7mvM68yyqi2ljw0ZYC9cVf0YzgKRTohVhihelpwZ+sBRGNYk
    OCu+u0Dr+EdVI3u5RNOxAELrbd4vYaS+2cCOfzmLABEBAAG0GkxhdW5jaHBhZCBQUEEgZm9y
    IFVidW50dS1YiLYEEwECACAFAkl1QosCGwMGCwkIBwMCBBUCCAMEFgIDAQIeAQIXgAAKCRA7
    IquXrxzfqY4HBACIQEFhl59ZkuIhTD3pmCQgfkhpcg0RVdB6Xwhu3QDJvmlWmrs+cofNMzyA
    7SwdjD9ARvhGbqHwub+T7oGiHlmFyodGypUZ4i/fdHsZYpsf34MwgYxhyNyOPY/jNImUE/yw
    kSI+kV5esWURH4j0jYfkaergFqCpDnsSkxuIvdjH2Q==
    =bkAa
    -----END PGP PUBLIC KEY BLOCK-----
    >Now open up gedit or any text editor you like and Cut+Past in the whole key. Then save the file with any name, like NewRepoKey_1

    >Back in the "Software Sources" GUI click on the "Authentication" Tab

    >Then click on the "Import Key File..." button and navigate to the key you saved and click OK.

    >Now click "close"

    >Now take a brake and have a e-smoke.

    >Now you can up grad you system through any of the multitudes of GUI's Ubuntu preinstalls

    Or just
    Code:
    sudo apt-get update && sudo apt-get upgrade
    --------------------------------------------------------------------------------------------

    If for some crazy reason all is not well and not working at all then you can Undo all this stuff by doing this.

    >Reboot and when the Grub is counting down form 3sec's hit enter.

    >Then select the Recovery mode.

    >When you get to the GUI arrow down and select "Root Shell"

    >When your in the Root Shell run this command to uninstall all the Catalyst driver stuff you installed.

    Code:
    apt-get remove fglrx-amdcccle fglrx-kernel-source xorg-driver-fglrx
    >Then replace the old xorg.conf file you backed up by running this command

    Code:
    mv /etc/X11/xorg.conf /etc/X11/xorg.conf-ati && mv /etc/X11/xorg.conf-bkp /etc/X11/xorg.conf
    >Now reboot and all should be just as it was before you messed it all up

    Code:
    reboot
    -------------------------------------------------------------------------------------------------------------
    OK, So now all is working, rock on.
    However, time go's on and we get a new kernel and if it brakes the ATI catalyst driver.
    All is not lost....

    This it what you will do to fix it.


    1> Go through all the steps I have up above to "Undo" all of the catalyst install. In the "If it didn't work for some crazy reason" section.

    2> Then you will boot up again after doing all that and you should be droped at the desktop using the Ubuntu default driver and the xorg.conf-bkp file you moved back to /etc/X11/xorg.conf by doing all the steps above. If not, like some craziness has gone down and all our laptops are not working with the default driver under the new Kernel. Well, I'll fix or if you do first post a HowTo in this thread for us all.
    All should be well though.

    3> Just start back at the top and reinstall the newest ATI catalyst driver by doing "ALL" of the steps that I have up above for installing the Catalyst driver, all over again.

    4> Reboot and all should be well again.
    -------------------------------------------------------------------------------------------------------------

    If your having problems with games like SuperTuxKart in the menu thinking your always pressing joydown. DanaG fixed this problem on his laptop. I have not tried it becuas I am useing an SSD so I don't care if the accelerometer is not set right and I don't have the joydown problem in Archlinux.

    Here is the quote form DanaG that can be found on the next page.

    Oh yeah, that "acts like joydown is pressed": try blacklisting lis3lv02d -- that's the driver that presents the accelerometer as a joystick. By default, the calibration has the X and Y axes swapped; I had to put this in my /etc/rc.local:
    jscal -u 3,1,0,2,0 /dev/input/js0 2>/dev/null || true
    -------------------------------------------------------------------------------------------------------------

    You can boot with the UEFI option. I will referer you to my other thread for UEFI/EFI development for the HP elitebook.

    Using EFI / UEFI with Linux on HP elitebook
    http://ubuntuforums.org/showthread.php?t=1157586

    -------------------------------------------------------------------------------------------------------------
    "Ubuntu" "linux" "how to" "ATI" "Catalyst" "driver" "8730" "HD3650" "FireGL" "Mobility FireGL v5700" "compatibility" "elitebook" "8530" "8530w" "8530p" "Solved" "Working" "Not Working" site:ubuntuforums.org
    Attached Files Attached Files
    Last edited by HunterThomson; May 19th, 2010 at 12:20 PM.
    Thinkpad W510, i7-720QM, Nvidia Quadro FX 880m (nouveau), Intel X25-M G2 80GB (OCZ are better), 1080p Wacom Multi-Touch Screen, Intel Centrino Advanced-N + WiMAX 6250, Yubikey OTP

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •