Is this still necessary with the latest ubuntu release?