Just reporting that this worked for me on an Acer Aspire 5050. Adding the line
options snd-hda-intel model=acer-aspire
Worked for me.
The speakers do not turn off when you put the headphones in, but it was that way even in Windows.