Results 1 to 6 of 6

Thread: Fresh install, Kwin problem (compositing not supported?)

  1. #1
    Join Date
    Jan 2009
    Beans
    66

    Fresh install, Kwin problem (compositing not supported?)

    When trying to enable KDE effects on a fresh install (nvidia driver installed) I am getting this message.

    Code:
    Compositing is not supported on your system.
    Required X extensions (XComposite and XDamage) are not available

    I tried to edit xorg.conf, and synaptic shows xcomposite and xdamage are indeed installed (the best I can tell)



    I installed fresh for a clean slate, I did not have this issue before hand.

    Any help is appreciated, thanks!

  2. #2
    Join Date
    Jan 2009
    Beans
    66

    Re: Fresh install, Kwin problem (compositing not supported?)

    Anyone have anything on this?

    Ive searched around and cant find anything more than adding a few lines to the xorg.conf file. Seems to have cleared this kind of thing up about a year ago.

    Maybe its my nvidia drivers ?

  3. #3
    Join Date
    Jan 2009
    Beans
    66

    Re: Fresh install, Kwin problem (compositing not supported?)

    Im using 180.37 btw

  4. #4
    Join Date
    Oct 2008
    Beans
    3

    Re: Fresh install, Kwin problem (compositing not supported?)

    The "few lines" you mention fixed me right up...

    Section "Extensions"
    Option "Composite" "Enable"
    EndSection

    I've seen others suggest testing whether glxgears (and thus openGL) is working on your machine...

    I'm not too bright, but am looking for places to comment on what worked for me after fiddling/googling this for a couple of hours before getting it to work.

    Daveee

  5. #5
    Join Date
    Jun 2006
    Beans
    596
    Distro
    Kubuntu

    Thumbs down Re: Fresh install, Kwin problem (compositing not supported?)

    What card have you got? For my 6200 I had to do
    Code:
    nvidia-xconfig
    on a blank xorg.conf.

  6. #6
    Join Date
    Jun 2006
    Location
    Queensland Australia
    Beans
    708
    Distro
    Kubuntu Development Release

    Question Re: Fresh install, Kwin problem (compositing not supported?)

    I have a similar post to this going but I had the same problem with 185.19 driver, I uninstalled it & reinstalled the 180.27 driver but now it fails to load! Gees I hate the whole prop driver issue in *buntu.


    Cary
    Ubuntu user 7859 registered Linux user 470405
    The Ubuntu Counter Project - user number # 7859"
    Lenovo T510 Kubuntu Trusty 64bit, Intel Core i5-560M, 8GB PC3-DDR3 SDRAM - 1067 MHz,
    NVIDIA NVS 3100m PCI Express, Wireless Centrino N 6300

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •