Results 1 to 6 of 6

Thread: [SOLVED] How can I disable the "Unlock Keyring" from popping up

  1. #1
    Join Date
    Dec 2007
    Location
    Portland, OR
    Beans
    151
    Distro
    Xubuntu 13.10 Saucy Salamander

    Question [SOLVED] How can I disable the "Unlock Keyring" from popping up

    I've searched other forum posts, but couldn't find the answer to my question. I am using a laptop to connect to my wireless network. Whenever I load up Ubuntu I must enter my password into the "Unlock Keyring". I read on another post to go to System > Preferences > Sessions and disable GNOME Keyring Daemon Wrapper, but I still receive the pop-up every time I log on. This seems like a relatively simple thing to figure out, and I know I've done it once before. Anyone know how I might be able to do this?
    - Chuck
    Toshiba C655-S5141 Laptop, dual-booting Xubuntu 13.10 and Win7, Intel Core i3 dual-core @ 2.53GHz, 8GB of RAM, 750GB HDD, replaced CD-drive with HDD caddy
    spacemonkeypdx.blogspot.com

  2. #2
    Join Date
    Dec 2007
    Location
    Portland, OR
    Beans
    151
    Distro
    Xubuntu 13.10 Saucy Salamander

    Re: How can I disable the "Unlock Keyring" from popping up

    Any ideas? Has anyone else experienced this?

    It only started popping up after I enabled automatic login.
    - Chuck
    Toshiba C655-S5141 Laptop, dual-booting Xubuntu 13.10 and Win7, Intel Core i3 dual-core @ 2.53GHz, 8GB of RAM, 750GB HDD, replaced CD-drive with HDD caddy
    spacemonkeypdx.blogspot.com

  3. #3
    Join Date
    Jun 2006
    Beans
    17

    Re: How can I disable the "Unlock Keyring" from popping up

    I am configuring this old laptop for my mom for Christmas and I would definitely love to make this go away. A login and password are going to be enough for her as it is. =)

    Edit:
    After a bit more searching, I followed the info here http://ubuntuforums.org/archive/index.php/t-320308.html especially the last several posts. Basically, set the default keyring password to blank (since I run Xfce4, I installed seahorse first to easily find it and not have to write scripts). Not very secure, but not much risk of anyone getting to her machine, so I also enabled automatic login, so all good for the techno-challenged configuration.
    Last edited by masinger53; December 24th, 2008 at 04:09 AM.

  4. #4
    Join Date
    Dec 2007
    Location
    Portland, OR
    Beans
    151
    Distro
    Xubuntu 13.10 Saucy Salamander

    Re: How can I disable the "Unlock Keyring" from popping up

    Quote Originally Posted by masinger53 View Post
    I am configuring this old laptop for my mom for Christmas and I would definitely love to make this go away. A login and password are going to be enough for her as it is. =)

    Edit:
    After a bit more searching, I followed the info here http://ubuntuforums.org/archive/index.php/t-320308.html especially the last several posts. Basically, set the default keyring password to blank (since I run Xfce4, I installed seahorse first to easily find it and not have to write scripts). Not very secure, but not much risk of anyone getting to her machine, so I also enabled automatic login, so all good for the techno-challenged configuration.
    Thanks for the link man, but unfortunately I ran into another wall.

    Heres what it says to do:
    To get rid of the keyring prompt after automatic login in hardy 8.04 you can:

    System > Preferences > Encryption and Keyrings
    Under Password Keyrings click on "login Automatically unlocked when user logs in."
    Click "Change Unlock Password"
    Enter your old password, but leave the new password fields blank.
    Ok , confirm and you should be set.
    When I go to the Encryption and Keyrings, I do not have a "Password Keyrings" or any option like that. I have only two tabs "Encryption" and "PGP Passphrases". Neither of these have any "login Automatically unlocked when user logs in" or "Change Unlock Password".

    I am using 8.10. Would these options be different in 8.10 than in 8.04?
    - Chuck
    Toshiba C655-S5141 Laptop, dual-booting Xubuntu 13.10 and Win7, Intel Core i3 dual-core @ 2.53GHz, 8GB of RAM, 750GB HDD, replaced CD-drive with HDD caddy
    spacemonkeypdx.blogspot.com

  5. #5
    Join Date
    Jun 2007
    Location
    K-o-T,
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: How can I disable the "Unlock Keyring" from popping up

    Try Applications > Accessories > Passwords and ...> Edit > Preferences and delete the login keyring and then add again and give it your login password.


    Good Luck
    Hypertension = Take with a pinch of salt
    | Psychocats | Ubuntu Documentation | Howto [Solved] | BBcode list | Brother Website |

  6. #6
    Join Date
    Dec 2007
    Location
    Portland, OR
    Beans
    151
    Distro
    Xubuntu 13.10 Saucy Salamander

    Lightbulb Re: How can I disable the "Unlock Keyring" from popping up

    Quote Originally Posted by plucky View Post
    Try Applications > Accessories > Passwords and ...> Edit > Preferences and delete the login keyring and then add again and give it your login password.


    Good Luck
    This worked. I restarted and had to restart again, but it worked. Thanks.
    - Chuck
    Toshiba C655-S5141 Laptop, dual-booting Xubuntu 13.10 and Win7, Intel Core i3 dual-core @ 2.53GHz, 8GB of RAM, 750GB HDD, replaced CD-drive with HDD caddy
    spacemonkeypdx.blogspot.com

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •