I just did the tutorial according to the first post with 8.10 Intrepid. And when I use the ffmpeg suggested by the post, I got the following error:

Code:
billh@billaspire:~/temp/ffmpeg/ffmpeg$ ffmpeg -y -i "/media/disk/DVD/cancer/avi/001/cancer-001.avi" -pass 1 -b 512k -bt 512k -s 640x480 -vcodec libx264 -an -threads 0 -coder 1 -flags +loop -cmp +chroma -partitions -parti8x8-parti4x4-partp8x8-partp4x4-partb8x8 -me_method dia -subq 1 -me_range 16 -g 250 -keyint_min 25 -sc_threshold 40 -i_qfactor 0.71 -b_strategy 1 -qcomp 0.6 -qmin 10 -qmax 51 -qdiff 4 -bf 16 -refs 1 -directpred 1 -bidir_refine 0 -trellis 0 -flags2 -bpyramid-wpred-mixed_refs-dct8x8+fastpskip -f mp4 /dev/null
FFmpeg version SVN-r15746, Copyright (c) 2000-2008 Fabrice Bellard, et al.
  configuration: --enable-gpl --enable-postproc --enable-libvorbis --enable-libtheora --disable-debug --enable-libmp3lame --enable-libfaad --enable-libfaac --enable-pthreads --enable-libx264 --enable-nonfree
  libavutil     49.12. 0 / 49.12. 0
  libavcodec    52. 1. 0 / 52. 1. 0
  libavformat   52.23. 1 / 52.23. 1
  libavdevice   52. 1. 0 / 52. 1. 0
  libpostproc   51. 2. 0 / 51. 2. 0
  built on Oct 30 2008 13:37:51, gcc: 4.3.2
Input #0, avi, from '/media/disk/DVD/cancer/avi/001/cancer-001.avi':
  Duration: 01:21:32.38, start: 0.000000, bitrate: 1640 kb/s
    Stream #0.0: Video: mpeg4, yuv420p, 720x480 [PAR 1:1 DAR 3:2], 29.97 tb(r)
    Stream #0.1: Audio: mp3, 48000 Hz, stereo, s16, 128 kb/s
Output #0, mp4, to '/dev/null':
    Stream #0.0: Video: libx264, yuv420p, 640x480 [PAR 9:8 DAR 3:2], q=10-51, pass 1, 512 kb/s, 29.97 tb(c)
Stream mapping:
  Stream #0.0 -> #0.0
[libx264 @ 0x9d515e0]no ratecontrol method specified
Error while opening codec for output stream #0.0 - maybe incorrect parameters such as bit_rate, rate, width or height
billh@billaspire:~/temp/ffmpeg/ffmpeg$
Notice my ffmpeg install was working fine with 8.10 + x264 + ffmpeg. The following command was working fine for me:
Code:
nice -n 18 /usr/bin/ffmpeg -y -i "/media/disk/DVD/cancer/avi/001/cancer-001.avi" -threads 2 -r 29.97 -b 400kb -vcodec libx264 -s 640x480 -acodec libfaac  -ab 64k -ar 48000 -ac 1 "/media/disk/DVD/cancer/avi/001/cancer.mp4"
I was just wondering why the command suggested by the post didn't work.