Results 1 to 8 of 8

Thread: Desktop effects could not be enabled

  1. #1
    Join Date
    Dec 2007
    Beans
    7
    Distro
    Xubuntu

    Desktop effects could not be enabled

    Hello there. I have the same problem, when trying to enable Desktop Effects, I get the error message "Desktop effects could not be enabled".

    I'm using Ubuntu 8.10 (and my system is 'up to date'), should I downgrade to 8.04?

    Also, I'm using the Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller driver (which doesn't appear to be propietary because if I open System >> Administration >> Hardware Drivers, the list appears to be empty).

    I've already commented some lines in the /usr/bin/compiz file in which my video card driver was blacklisted.

    What else can I do to make it work?

    This is the output the "compiz" command spews out in a terminal:
    Code:
    Checking for Xgl: not present. 
    Detected PCI ID for VGA: 
    Checking for texture_from_pixmap: not present. 
    Trying again with indirect rendering:
    Checking for texture_from_pixmap: present. 
    Checking for non power of two support: present. 
    Checking for Composite extension: present. 
    Comparing resolution (1280x960) to maximum 3D texture size (2048): Passed.
    Checking for Software Rasterizer: present. 
    Software rasterizer detected, aborting aborting and using fallback: /usr/bin/metacity

  2. #2
    Join Date
    Feb 2007
    Beans
    23,169
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Desktop effects could not be enabled

    Moved to Intrepid

  3. #3
    Join Date
    Feb 2008
    Beans
    257

    Re: Desktop effects could not be enabled

    I have this same exact problem, when I go to add xserver-xgl it says:

    xserver-xgl:

    Package xserver-xgl has no available version, but exists in the database.
    This typically means that the package was mentioned in a dependency and never uploaded, has been obsoleted or is not available with the contents of sources.list


    I am using 8.10

  4. #4
    Join Date
    Dec 2005
    Location
    Melbourne, Victoria, AU
    Beans
    408
    Distro
    Ubuntu Development Release

    Re: Desktop effects could not be enabled

    Xgl is obsolete, dead, and has been removed. You should use something more normal.
    William Grant
    Ubuntu Developer

  5. #5
    Join Date
    Sep 2006
    Beans
    Hidden!

    Re: Desktop effects could not be enabled

    Quote Originally Posted by wgrant View Post
    Xgl is obsolete, dead, and has been removed. You should use something more normal.
    I guess you don't have to be helpful to be a developer.

  6. #6
    Join Date
    Dec 2005
    Location
    Melbourne, Victoria, AU
    Beans
    408
    Distro
    Ubuntu Development Release

    Re: Desktop effects could not be enabled

    Quote Originally Posted by hyper7 View Post
    I guess you don't have to be helpful to be a developer.
    While perhaps true, I lacked time at that point to post a full solution to the original poster's solution. I thus decided to quickly point out that Xgl was a dead end, and a solution which should not be pursued.
    William Grant
    Ubuntu Developer

  7. #7
    Join Date
    Oct 2005
    Location
    Southern Ontario, Canada
    Beans
    1,244
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Desktop effects could not be enabled

    "sudo dpkg-reconfigure xserver-xorg" fixed it for me
    There is an easy way, and a hard way to do things.
    If you're anything like me, you've tried to do things things the hard way,

    and broke something.......

    (\ /)
    (O.o)
    (> <)

  8. #8
    Join Date
    Oct 2008
    Beans
    15

    Re: Desktop effects could not be enabled

    I'm just messing around with Intrepid from a Live USB stick right now and experience a similar problem.

    Via the Resolution Settings I can either Mirror my two screens (12.1" Laptop/1280x800; 20" external/1680x1050) and when I do that the Desktop Effects work fine. However with Mirror I can only select a resolution as high as 1024x768. When I disable Mirror I get a dual screen display with both screens in the right resolution (which is really nice, because I never got that to work) but can't set up desktop effects.

    When dual screen is on 'compiz' complains:
    Code:
    Comparing resolution (2960x1050) to maximum 3D texture size (2048): Failed.
    When I set the resolution of my laptop screen to Off 'compiz' complains as well:
    Code:
    Comparing resolution (1680x1050) to maximum 3D texture size (2048): Passed.
    Checking for Software Rasterizer: present. 
    Software rasterizer detected, abortingaborting and using fallback: /usr/bin/metacity
    I hope anyone can help. I'd love to use native resolutions and Desktop Effects.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •