Results 1 to 3 of 3

Thread: Unable to Enable Desktop Effects in KDE using FGLRX

  1. #1
    Join Date
    Jan 2006
    Beans
    9

    Unable to Enable Desktop Effects in KDE using FGLRX

    Desktop effects in KDE using kwin work out of the box using the open source ati drivers. However, once fglrx is enabled, selecting "enable desktop effects" under system systems produces no result. Do the fglrx drivers have to be configured in a certain way to allow compositing, or is it something else?

  2. #2
    Join Date
    Jun 2006
    Location
    Roanoke, VA
    Beans
    152
    Distro
    Ubuntu Development Release

    Re: Unable to Enable Desktop Effects in KDE using FGLRX

    Which ATI card are you using? Did you install FGLRX using the restricted drivers panel, or manually using the download from ATI? The latest (Catalyst 8.10) is already in the Ubuntu repos and is enabled easily in the Hardware Drivers dialog.

    Have you tried running the following, to make sure it's not a configuration issue?
    sudo aticonfig --initial -f
    Last edited by JPorter; October 18th, 2008 at 07:18 PM.

  3. #3
    Join Date
    Jan 2007
    Beans
    1,010
    Distro
    Kubuntu Development Release

    Re: Unable to Enable Desktop Effects in KDE using FGLRX

    The Canonical version of fglrx works with Xorg 7.4. The "official" AMD version does not. Which are you using?
    (btw, you can still use XRender to get some compositing, but that doesn't solve the real problem.)
    my shiz: http://inportb.com/
    use Dropbox if you need an awesome free file hosting service; please follow my referral link for an extra 256MB of free storage.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •