Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: GRUB: Ubuntu after Vista = Vista gone!

  1. #1
    Join Date
    Jun 2008
    Beans
    18

    Unhappy GRUB: Ubuntu after Vista = Vista gone!

    Hello,

    I've a problem, I have a new PC with a 750GB SATA disk, with 3 partitions on it:

    1st partition: 200GB: Windows Vista Ultimate 32-bit (NTFS)
    2nd partition: 150GB: Linux Ubuntu 8.10 (Bčta) 32-bit (EXT3)
    3rd partition: 400GB: Storage & Backup (NTFS)

    First, I installed Vista, then, when the Bčta was released, I installed Ubuntu 8.10 Bčta (it is great btw). But the GRUB doesn't show Vista in the list (you know, when the pc boots, you get a screen where you can select the OS you want to boot). I already tried modifying the menu.lst, and reďnstall the GRUB, reďnstall the Windows Boot Loader, overwrite the MBR, etc. But I can't get Vista to boot!!

    In the 'fresh' menu.lst, there was no Vista at all, and when I do it manually it can't recognize the device. Except when I say the Windows root is (hd0,2). But then 'something' says that bootmngr is missing. Ubuntu 8.10 however is in the list, and boots perfectly.

    Both Ubuntu and Vista partitions can be removed (there's no important data on them), but the 3rd partition HAS TO REMAIN WERE IT IS! Only in case of emergency I can back-up the back-ups to another HDD.

    I hope you can help me, I use Vista for games, and I game a lot!

    Fleuris

  2. #2
    Join Date
    Jan 2006
    Location
    Iberian Peninsula
    Beans
    352

    Smile Re: GRUB: Ubuntu after Vista = Vista gone!

    Quote Originally Posted by Fleuris View Post
    1st partition: 200GB: Windows Vista Ultimate 32-bit (NTFS)
    2nd partition: 150GB: Linux Ubuntu 8.10 (Bčta) 32-bit (EXT3)
    3rd partition: 400GB: Storage & Backup (NTFS)

    But I can't get Vista to boot!!
    If you are right about Vista being in the first partition check: http://www.supergrubdisk.org/wiki/Ho...#Grub_solution

    If it still does not work activate the Vista partition from the Super Grub Disk's Boot & Tools -> Activate partitions menu.

    If it still does not work please post Hard Disks partition layout from Super Grub Disk point of view.


    adrian15

  3. #3
    Join Date
    Jun 2008
    Beans
    18

    Re: GRUB: Ubuntu after Vista = Vista gone!

    Quote Originally Posted by adrian15
    If you are right about Vista being in the first partition check: http://www.supergrubdisk.org/wiki/Ho...#Grub_solution

    If it still does not work activate the Vista partition from the Super Grub Disk's Boot & Tools -> Activate partitions menu.

    If it still does not work please post Hard Disks partition layout from Super Grub Disk point of view.


    adrian15
    I'll try that, thanks!

    I've just tried installing Ubuntu 8.04 on another partition, but even that won't work. The GRUB shows both Ubuntu's, but no Windows Vista!

  4. #4
    Join Date
    Mar 2008
    Location
    California, USA
    Beans
    8,111

    Re: GRUB: Ubuntu after Vista = Vista gone!

    Quote Originally Posted by adrian15 View Post
    If it still does not work activate the Vista partition from the Super Grub Disk's Boot & Tools -> Activate partitions menu.

    adrian15
    Just out of curiosity, I followed that link you give above for "activate partitions", and it doesn't say what is does; does it set the boot flag on the partition, i.e. make it the "active" partition?

  5. #5
    Join Date
    Jan 2006
    Location
    Iberian Peninsula
    Beans
    352

    Re: GRUB: Ubuntu after Vista = Vista gone!

    Quote Originally Posted by caljohnsmith View Post
    Just out of curiosity, I followed that link you give above for "activate partitions", and it doesn't say what is does; does it set the boot flag on the partition, i.e. make it the "active" partition?
    Yes, you are right.

  6. #6
    Join Date
    Jan 2006
    Location
    Iberian Peninsula
    Beans
    352

    Wink Re: GRUB: Ubuntu after Vista = Vista gone!

    Quote Originally Posted by Fleuris View Post
    I'll try that, thanks!

    I've just tried installing Ubuntu 8.04 on another partition, but even that won't work. The GRUB shows both Ubuntu's, but no Windows Vista!
    Try it and Vista entry will appear. Depending on your setup it might boot or not (multiple hard disk give some headaches sometimes).

    adrian15

  7. #7
    Join Date
    Jun 2008
    Beans
    18

    Unhappy Re: GRUB: Ubuntu after Vista = Vista gone!

    All right, I tried everything you wrote, and nothing has worked!

    I made my menu.lst look like this: (this is my menu.lst)
    ## ## End Default Options ##

    title Ubuntu intrepid (development branch), kernel 2.6.27-7-generic
    root (hd0,5)
    kernel /boot/vmlinuz-2.6.27-7-generic root=UUID=2449953c-591f-4d3d-a048-3a216f7755ea ro quiet splash
    initrd /boot/initrd.img-2.6.27-7-generic
    quiet

    title Ubuntu intrepid (development branch), kernel 2.6.27-7-generic (recovery mode)
    root (hd0,5)
    kernel /boot/vmlinuz-2.6.27-7-generic root=UUID=2449953c-591f-4d3d-a048-3a216f7755ea ro single
    initrd /boot/initrd.img-2.6.27-7-generic

    title Ubuntu intrepid (development branch), kernel 2.6.27-4-generic
    root (hd0,5)
    kernel /boot/vmlinuz-2.6.27-4-generic root=UUID=2449953c-591f-4d3d-a048-3a216f7755ea ro quiet splash
    initrd /boot/initrd.img-2.6.27-4-generic
    quiet

    title Ubuntu intrepid (development branch), kernel 2.6.27-4-generic (recovery mode)
    root (hd0,5)
    kernel /boot/vmlinuz-2.6.27-4-generic root=UUID=2449953c-591f-4d3d-a048-3a216f7755ea ro single
    initrd /boot/initrd.img-2.6.27-4-generic

    title Ubuntu intrepid (development branch), memtest86+
    root (hd0,5)
    kernel /boot/memtest86+.bin
    quiet

    title Windows
    rootnoverify (hd0,0)
    makeactive
    chainloader +1
    boot

    ### END DEBIAN AUTOMAGIC KERNELS LIST
    But when I try to boot Windows, it says: "Error 12: Invalid device requested"

    The I tried to activate the partition with my Windows (hd0,4), but then it also says: "Error 12: Invalid device requested" this message is in the SGD.

    Now, here is my layout, I hope you can help me out:
    fdisdklu
    6 (hd0,5) ext2fs 141GB Ubuntu inteprid (development branch) \n \l
    pause SGD has succeeded!
    SGD has succeeded!
    And here is my overview of my partitions, from SGD:
    N IDE SCSI GRUB HURD TYPE SIZE OS
    3 hda3 sda3 (hd0,2) hd0s3 NTFS 356GB Windows
    5 hda5 sda5 (hd0,4) hd0s5 NTFS 195GB Windows
    6 hda6 sda6 (hd0,5) hd0s6 ext2fs 141GB Ubuntu inteprid
    7 hda7 sda7 (hd0,6) hd0s7 Swap 4GB

  8. #8
    Join Date
    Mar 2008
    Location
    California, USA
    Beans
    8,111

    Re: GRUB: Ubuntu after Vista = Vista gone!

    It would help if you could post:
    Code:
    sudo fdisk -lu
    Which I assume is what the SGD output you posted is, but it shows your Windows is not on sda1; you have two NTFS partitions, sda3 and sda5 according to SGD. Do you know which one is Vista? Try changing your Windows entry in your menu.lst to:
    Code:
    title Windows Vista
    rootnoverify (hd0,2)
    makeactive
    chainloader +1
    And let me know what happens when you try it on start up. If it doesn't work, please post the output of:
    Code:
    sudo mount /dev/sda3 /mnt
    ls -l /mnt
    Note "-l" is a lowercase L, not a one.

  9. #9
    Join Date
    Jan 2006
    Location
    Iberian Peninsula
    Beans
    352

    Unhappy Re: GRUB: Ubuntu after Vista = Vista gone!

    Quote Originally Posted by Fleuris View Post
    But when I try to boot Windows, it says: "Error 12: Invalid device requested"
    Can you please remove the makeactive line and see what it happens?

    Quote Originally Posted by Fleuris View Post
    The I tried to activate the partition with my Windows (hd0,4), but then it also says: "Error 12: Invalid device requested" this message is in the SGD.
    Interesting.

    Quote Originally Posted by Fleuris View Post
    Now, here is my layout, I hope you can help me out:
    If you use 0.9766 SGD version I definitely need to fix it because it should show you all the lines and not only one line.

    Quote Originally Posted by Fleuris View Post
    And here is my overview of my partitions, from SGD:
    From Boot & Tools -> Show Partitions menu, isn't it?

    Let's see you can try this on your menu.lst (see that there is not a makeactive command):

    Code:
    title win
    rootnoverify (hd0,2)
    chainloader +1
    boot
    adrian15

  10. #10
    Join Date
    Jun 2008
    Beans
    18

    Re: GRUB: Ubuntu after Vista = Vista gone!

    Here is the result of 'sudo fdisk -lu':

    Disk /dev/sda: 750.1 GB, 750156374016 bytes
    255 heads, 63 sectors/track, 91201 cylinders, total 1465149168 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Disk identifier: 0x6570e6d8

    Device Boot Start End Blocks Id System
    /dev/sda1 16065 716788169 358386052+ f W95 Ext'd (LBA)
    /dev/sda3 * 716802048 1465145343 374171648 7 HPFS/NTFS
    /dev/sda5 16128 409593239 204788556 7 HPFS/NTFS
    /dev/sda6 409593303 707036714 148721706 83 Linux
    /dev/sda7 707036778 716788169 4875696 82 Linux swap / Solaris

    result of /mnt:

    total 28
    drwxrwxrwx 1 root root 0 2008-10-13 21:55 Backup
    drwxrwxrwx 1 root root 4096 2008-10-11 14:40 Bewaar
    drwxrwxrwx 1 root root 0 2008-10-13 23:36 Boot
    drwxrwxrwx 1 root root 12288 2008-10-12 18:35 Downloads
    drwxrwxrwx 1 root root 4096 2008-10-11 12:41 Games
    drwxrwxrwx 1 root root 0 2008-10-11 23:10 Muziek
    drwxrwxrwx 1 root root 0 2008-10-12 10:12 $RECYCLE.BIN
    drwxrwxrwx 1 root root 0 2008-10-11 16:37 RECYCLER
    drwxrwxrwx 1 root root 4096 2008-10-11 14:36 System Volume Information
    drwxrwxrwx 1 root root 4096 2008-10-12 18:12 Torrent
    sda3 is my backup partition, sda5 is the partition with windows vista on it. I already tried 'rootnoverify (hd0,2)', is says that BOOTMNGR is missing, when I reinstall the Vista bootmanager, it doesn't help. But I will try it without 'makeactive'

    I'm using the newest version of SGD (downloaded 2 days ago)

    I'm now going to try booting without the 'makeactive' command.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •