I have the same problem on an Inspiron 1525, and I know why, but struggling to do anything about it.

There are 2 reasons why the touchpad jumps around, it's because circular scrolling is enabled in touchpad preferences (the GUI isn't actually installed with Ubuntu), and because it thinks there's another mouse attached.

I used to run Suse 11.0, and to get the touchpad working, you had to disable the apparition of another mouse in the sax2 module. In my xorg.conf [Ubuntu] (sudo gedit /etc/X11/xorg.conf), it can see another mouse, while I don't have one. In Suse, you went through Yast/Sax2 to remove it. I can't find the equivalent in ubuntu.

There was also an option of Touchpad settings, which you adjust, and turn off circular scrolling (which makes it jump all over the place). You can install "Touchpad" from Add/Remove Programs, but it won't initialise, giving the error message:
GSynaptics couldn't initialize.
You have to set 'SHMConfig' 'true' in xorg.conf or XF86Config to use GSynaptics

I added the line
Option "SHMConfig" "true"


but it still comes up with the same error message. I'm investigating the XF86Config at the mo.

Any ideas?