Results 1 to 4 of 4

Thread: [SOLVED] Help compiling Word War Vi

  1. #1
    Join Date
    Mar 2008
    Location
    Snohomish, WA
    Beans
    38
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Question [SOLVED] Help compiling Word War Vi

    I'm trying to install the game "Word War Vi".

    I'm using the guide at http://www.savvyadmin.com/word-war-vi-in-ubuntu/. I've installed every program (except for the gnome-core-devel package, as I'm using KDE) listed, and probably a billion more, but when I try to compile using the "make" and the "make install" commands, it gives me a million error messages and won't do anything. I don't understand the messages, as I'm not a programmer. I really don't know if all this trouble is worth it for one game, but if there is an easy fix, please let me know.

  2. #2

    Re: Help compiling Word War Vi

    Hello.

    I am the author of Word War vi.

    What error messages are you getting?

    -- steve

  3. #3

    Re: Help compiling Word War Vi

    Just noticed this:
    (except for the gnome-core-devel package, as I'm using KDE)
    This is a problem, as Word War vi is a gnome program (by which I mean it uses lots of GTK and gdk libs and header files.) The instructions at savvyadmin.com say:
    Install Prerequisites and Dependencies

    $ sudo apt-get install build-essential gnome-core-devel portaudio19-dev libvorbis-dev
    gnome-core-devel is in that list because it is *required*.

    Having the gnome libs and header files around isn't going to harm your KDE setup, (apart from taking up space on your disk.)

  4. #4
    Join Date
    Mar 2008
    Location
    Snohomish, WA
    Beans
    38
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Help compiling Word War Vi

    Quote Originally Posted by rumplefreakinstiltskin View Post
    Just noticed this:

    This is a problem, as Word War vi is a gnome program (by which I mean it uses lots of GTK and gdk libs and header files.) The instructions at savvyadmin.com say:

    gnome-core-devel is in that list because it is *required*.

    Having the gnome libs and header files around isn't going to harm your KDE setup, (apart from taking up space on your disk.)
    Okay, thank you. That explains why I'm getting these messages. I'll install those files now. Anyways, even though I haven't actually /played/ the game yet, the concept of the game is really cool.

    --------

    And it worked!
    Last edited by GregMB; August 29th, 2008 at 07:01 PM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •