Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Kill Switch issue (?) with Intel 4965AGN

  1. #1
    Join Date
    Oct 2007
    Location
    Göteborg
    Beans
    44
    Distro
    Kubuntu 9.04 Jaunty Jackalope

    Kill Switch issue (?) with Intel 4965AGN

    Hi.

    I just bought a new Titan A15 laptop from Zepto Computers and I'm having some problems. I chose Intel 4965 AG/N, a wireless NIC that I thought would be well supported "out of the box" (see https://help.ubuntu.com/community/Ha...workCardsIntel), but I can't seem to enable it. I cannot find any networks, knowing that my router works great with other computers and that there are several other networks in my vicinity.

    Here's some info:
    $ iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.

    wmaster0 no wireless extensions.

    wlan0 IEEE 802.11a ESSID:"" Nickname:""
    Mode:Managed Channel:0 Access Point: Not-Associated
    Tx-Power=0 dBm
    Retry min limit:7 RTS thrff Fragment thr=2346 B
    Power Managementff
    Link Quality:0 Signal level:0 Noise level:0
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0
    $ lspci -v
    02:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN Network Connection (rev 61)
    Subsystem: Intel Corporation Unknown device 1101
    Flags: fast devsel, IRQ 16
    Memory at d4100000 (64-bit, non-prefetchable) [size=8K]
    Capabilities: <access denied>
    $ sudo lshw -C network
    ---
    *-network
    description: Ethernet interface
    product: 191 Gigabit Ethernet Adapter
    vendor: Silicon Integrated Systems [SiS]
    physical id: 4
    bus info: pci@0000:00:04.0
    logical name: eth0
    version: 02
    serial: 00:1b:38:e2:b6:ed
    size: 100MB/s
    capacity: 100MB/s
    width: 32 bits
    clock: 33MHz
    capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
    configuration: autonegotiation=on broadcast=yes driver=sis190 driverversion=1.2 duplex=full ip=192.168.1.100 latency=0 link=yes module=sis190 multicast=yes port=MII speed=100MB/s
    *-network DISABLED
    description: Wireless interface
    product: PRO/Wireless 4965 AG or AGN Network Connection
    vendor: Intel Corporation
    physical id: 0
    bus info: pci@0000:02:00.0
    logical name: wmaster0
    version: 61
    serial: 00:1d:e0:7b:56:79
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress cap_list logical ethernet physical wireless
    configuration: broadcast=yes driver=iwl4965 latency=0 module=iwl4965 multicast=yes wireless=IEEE 802.11a
    Note that this says wmaster0, but iwconfig says that it's wlan0 that's used, right..?

    Well, what I personally suspect is the problem is that I have a hardware switch on my laptop for WLAN, and a led to indicate when WLAN or Bluetooth is activated. I have never seen that led alight. When "turning" the switch the first time after a reboot, I get this in dmesg:
    [ 96.353679] iwl4965: Radio disabled by HW RF Kill switch
    [ 96.353733] ACPI: PCI interrupt for device 0000:02:00.0 disabled
    [ 96.367329] eth0: PHY reset until link up.
    Switching it again back and forth, I only get
    [ 98.452569] atkbd.c: Unknown key pressed (translated set 2, code 0xf1 on isa0060/serio0).
    [ 98.452574] atkbd.c: Use 'setkeycodes e071 <keycode>' to make it known.
    [ 98.453086] atkbd.c: Unknown key released (translated set 2, code 0xf1 on isa0060/serio0).
    [ 98.453089] atkbd.c: Use 'setkeycodes e071 <keycode>' to make it known.
    [ 99.441153] eth0: PHY reset until link up.
    [ 101.312324] atkbd.c: Unknown key pressed (translated set 2, code 0xf1 on isa0060/serio0).
    [ 101.312330] atkbd.c: Use 'setkeycodes e071 <keycode>' to make it known.
    [ 101.314116] atkbd.c: Unknown key released (translated set 2, code 0xf1 on isa0060/serio0).
    etc, etc.

    Could I do some keymapping, or simply disable the switch all together, keeping the wireless on at all times?

    Previously, I had problems getting it to show up anywhere at all, but installing linux-backports-modules-hardy solved that. Then, the network card didn't show up as DISABLED as it does now.

    I'd be very, very grateful for any kind of help or hints, anything to get me started to do more research myself. Thanks.

  2. #2
    Join Date
    Oct 2007
    Location
    Göteborg
    Beans
    44
    Distro
    Kubuntu 9.04 Jaunty Jackalope

    Re: Kill Switch issue (?) with Intel 4965AGN

    Also;
    $ sudo iwlist wlan0 scan
    wlan0 Interface doesn't support scanning : Network is down

    $ sudo iwlist wmaster0 scan
    wmaster0 Interface doesn't support scanning.
    Wether my kill switch is on or off, and cat 5 connected or not.

    &

    $ uname -a
    Linux munin 2.6.24-19-generic #1 SMP Fri Jul 11 23:41:49 UTC 2008 i686 GNU/Linux
    Last edited by Creap; August 2nd, 2008 at 12:31 PM.

  3. #3
    Join Date
    Jul 2005
    Location
    England
    Beans
    Hidden!

    Re: Kill Switch issue (?) with Intel 4965AGN

    This may not have anything to do with your problem but where did your kernel come from and what is the munin kernel? Have you used something different to the usual ubuntu kernel, which is what I see from the uname -a command?

  4. #4
    Join Date
    Oct 2007
    Location
    Göteborg
    Beans
    44
    Distro
    Kubuntu 9.04 Jaunty Jackalope

    Re: Kill Switch issue (?) with Intel 4965AGN

    Quote Originally Posted by ajgreeny View Post
    This may not have anything to do with your problem but where did your kernel come from and what is the munin kernel? Have you used something different to the usual ubuntu kernel, which is what I see from the uname -a command?
    Munin is just the name of my computer... My kernel is from the upgrade manager.

  5. #5
    Join Date
    Jul 2005
    Location
    England
    Beans
    Hidden!

    Re: Kill Switch issue (?) with Intel 4965AGN

    OK, thanks. My computer is named ubuntu804, so I didn't realise the output would contain that in the line from uname -a.

  6. #6
    Join Date
    Oct 2007
    Location
    Göteborg
    Beans
    44
    Distro
    Kubuntu 9.04 Jaunty Jackalope

    Re: Kill Switch issue (?) with Intel 4965AGN

    I still have the same problem. I've also tried a solution for iwl3945 suggested in another thread:
    Code:
    sudo su
    echo -e 'alias wlan0 iwl3945 \noptions iwl3945 disable_hw_scan=1' > /etc/modprobe.d/iwl3945
    reboot
    replacing iwl3945 with iwl4965 of course. That didn't help, so I removed /etc/modprobe.d/iwl4965 again.

    Now my dmesg says "iwl4965: Wait for START_ALIVE timeout after 2000ms." over and over again... All other commands used in the original post give the same results.

    Plz help!#@

  7. #7
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,561
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: Kill Switch issue (?) with Intel 4965AGN

    Would you please open a terminal and do:
    Code:
    sudo su
    echo "0" > /sys/bus/pci/drivers/iwl4965/*/rf_kill
    sudo lshw -C network
    Is you card still DISABLED? If not, can you configure and connect? If so, we can work out how to make this permanent.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  8. #8
    Join Date
    Oct 2007
    Location
    Göteborg
    Beans
    44
    Distro
    Kubuntu 9.04 Jaunty Jackalope

    Re: Kill Switch issue (?) with Intel 4965AGN

    Quote Originally Posted by chili555 View Post
    Would you please open a terminal and do:
    Code:
    sudo su
    echo "0" > /sys/bus/pci/drivers/iwl4965/*/rf_kill
    sudo lshw -C network
    Is you card still DISABLED? If not, can you configure and connect? If so, we can work out how to make this permanent.
    all commands worked without errors, but I still get the exact same results for lshw -C network as above, still DISABLED

  9. #9
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,561
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: Kill Switch issue (?) with Intel 4965AGN

    I am running low on ideas, but here is another thing to try:
    Code:
    sudo rmmod iwl4965
    sudo modprobe iwl4965 disable=0
    sudo lshw -C network
    Is your card still disabled?
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  10. #10
    Join Date
    Oct 2007
    Location
    Göteborg
    Beans
    44
    Distro
    Kubuntu 9.04 Jaunty Jackalope

    Re: Kill Switch issue (?) with Intel 4965AGN

    Quote Originally Posted by chili555 View Post
    I am running low on ideas, but here is another thing to try:
    Code:
    sudo rmmod iwl4965
    sudo modprobe iwl4965 disable=0
    sudo lshw -C network
    Is your card still disabled?
    I'm afraid so, yes. Still the exact same results for lshw as above.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •