Results 1 to 5 of 5

Thread: Can't run nvidia-settings

  1. #1
    Join Date
    Jul 2005
    Location
    Trowbridge, UK
    Beans
    77
    Distro
    Ubuntu 8.04 Hardy Heron

    Can't run nvidia-settings

    Hi - I've recently installed a new graphics card MSI GeForce NX7300, and the screen colours look very weird. I have fiddled with my monitor as best I can but believe the problem would be best fixed by running nvidia-settings and adjusting the brightness/contrast/gamma.

    However, when I do I get this error:
    Code:
    You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server.
    Running nvidia-xconfig and a reboot does not fix this error.

    I have tried using envy to install drivers, nvidia-glx-new and have currently settled on nvidia-glx. Note all three drivers provide me with excellent 3d graphics and compiz looks great I just can't run nvidia-settings.

    I really need to get this fixed as it's very hard to work for long periods of time with the current screen settings. Please help!

  2. #2
    Join Date
    Jun 2007
    Location
    Newcastle, UK
    Beans
    Hidden!
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Can't run nvidia-settings

    Hi,

    Try this, System>Admin>Restricted-drivers, when the window opens check the enable box, either it will download the appropiate driver or update the existing one, if that doesnt help then try this:
    check to see of you have a package called:
    nvidia-settings
    (synaptic) install if not, then, in a terminal type in:

    gksudo nvidia-settings

    I believe its the second option down (trial and error) which changes the resolution etc, hope this helps.

    Regards, Ellgor.

  3. #3
    Join Date
    Jul 2005
    Location
    Trowbridge, UK
    Beans
    77
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Can't run nvidia-settings

    Ellgor - thank you for your comments, but as stated in my original post I have attempted to install the suggested driver and have run nvidia-settings.

    I also tried it using gksudo with the same effect.

    Any further thoughts would be greatfully recieved.

  4. #4
    Join Date
    Feb 2008
    Location
    US
    Beans
    2,782
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Can't run nvidia-settings

    can you post your xorg file (/etc/X11/xorg.conf)
    Desktop: Q6600 OC: 343 x 9, 4 GB RAM, 8600 GTS Twinview (22",17"), 1.5 TB RAID 5
    Laptop: Lenovo T61 T7300 @ 2 GHz, 2GB RAM, Nvidia 140M Quadro, 160 GB harddrive
    Remember to mark posts as [SOLVED] when your problem is resolved

  5. #5
    Join Date
    Jul 2005
    Location
    Trowbridge, UK
    Beans
    77
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Can't run nvidia-settings

    I'd be happy to do so, but the problem resides on my work computer. I haven't yet set up ssh/vpn so I can't do this until I'm back in the office on friday.

    Will do so then.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •