Sorry for the double post, thought it might be good to bump this topic.

I just tried the mini.iso that was giving me the error as before but this time, the package was different.

Loading kickseed-common failed for unknown reasons. Aborting
Do I need to get a replacement mini.iso?