Results 1 to 4 of 4

Thread: .awesomerc.lua troubles

  1. #1
    Join Date
    Oct 2006
    Location
    Kansas City
    Beans
    1,509
    Distro
    Ubuntu 10.04 Lucid Lynx

    .awesomerc.lua troubles

    so i decided to give awesome a try again, and with a little help from this oh so excellent quick rundown i managed to get awesome 3 installed and running
    http://github.com/gigamo/config/wiki...e-3-git-branch

    the only problem is... any time i try to use any .awesomerc.lua example i find on the web (and believe me, there's not many), awesome wont load... it starts to, but then just stops, usually locking up my entire pc. It will load and work fine with the example file that comes with awesome, so i've managed to make a few edits to change colors, etc. but i am in no way shape or form very good at this aparently.

    ones i've tried to modify and use are:
    http://github.com/rhaamo/rhaamo-conf....awesomerc.lua
    http://github.com/xorg62/xorg62-s-co.../awesomerc.lua
    http://git.glacicle.com/configs.git/.awesomerc.lua
    http://www.calmar.ws/dotfiles/dotfil..._awesomerc.lua

    i have (at least i hope i have, it was an awfully simple process for each) installed wicked and eminent... awful of course comes with it, and i cant find any refrence to "rules" anywhere... and i even tried the one that doesnt rely on anything except the stock "awful" but to no avail...

    i've made sure to edit/remove any widgets i didnt want and or didnt have the seperate scripts involved to use... i've edited/removed most of the iconboxes since i dont have very good icons yet... and still no luck running anything other than the stock example.

    i could just edit this file, but im no expert in lua and i barely grasped awesome 2.0/2.1 rc file

    any ideas or suggestions as to why i cant run any of those, and any other examples from you awesome 3 users out there would be much appreciated.

  2. #2
    Join Date
    Oct 2006
    Location
    Kansas City
    Beans
    1,509
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: .awesomerc.lua troubles

    so after further tinkering, it is in fact a problem with wicked and eminent... i knew they were to easy to install...

    basically i got them git, then copied the .lua files over to /usr/local/share/awesome/libs wich is what the instructions said... but for some reason, they arent liking to work... any clues on any missed steps i might have taken there???

  3. #3
    Join Date
    Jun 2007
    Beans
    638
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: .awesomerc.lua troubles

    Dunno but for me, I've stuck with v 2.1, and am still happy with it.
    Ubuntu User # 17490
    Currently: Fisheye 2, Diana F+, Viv UWS
    Lomografix

  4. #4
    Join Date
    Oct 2006
    Location
    Kansas City
    Beans
    1,509
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: .awesomerc.lua troubles

    yeah, i think when i get around to reformatting ill probably go with 2.1 or 2.3... 3 is great and all, but its still a bit buggy i've found... its crashed about 5 times on me switchign between max tags containing vlc and firefox...

    now that i've finally gotten around to awesome i think its become my new number one wm and it will probably be the only one i install on my next reformat, just wish i was a programmer (seems like ya darn near have to be just to configure a decent wm now a days, haskel in xmonad, lua in awesome, etc)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •