Results 1 to 7 of 7

Thread: No surround sound

  1. #1
    Join Date
    Jan 2008
    Beans
    10

    No surround sound

    I've unsuccessfully been trying to get my 5:1 surround sound working since upgrading to hardy, after extensive googling and searching on various forums and blogs, testing dozens of howtos I'm close to giving up .

    However, I had it working in the alphas (after following some howto) but I lost it in the beta... I'm assuming it has do with an updated kernel?
    Right now I'm stuck with just 2 speakers + the subwoofer, the other 3 speakers are quiet.


    Soundcard: nVidia Corporation MCP67 High Definition Audio

    Could someone please give me a hand getting this to work? thanks.

  2. #2
    Join Date
    Jul 2006
    Location
    Castrum, Germania Secunda
    Beans
    1,071

    Re: No surround sound

    Try this:
    http://ubuntutip.googlepages.com/sound

    However, a clean installation is always best:
    http://ubuntutip.googlepages.com/upgrading
    Tips, tweaks and how-to's for Ubuntu and Mint:
    http://sites.google.com/site/easylinuxtipsproject
    In for a pleasant surprise? Give Xubuntu a try:
    http://sites.google.com/site/easylin...roject/xubuntu

  3. #3
    Join Date
    Jan 2008
    Beans
    10

    Re: No surround sound

    Well, that didn't help I'm afraid. The link gives some instructions on specific cards that I don't have, or move the sliders in alsamixer (those don't show up for me). and advising me to wait for a new release (which I shouldn't need to because it worked before).

    And yes, it is a clean install already

    Thanks for trying

  4. #4
    Join Date
    Feb 2008
    Beans
    1,031

    Re: No surround sound

    I'll probably offend your intelligence by suggesting this, but I'll say it anyway

    If you open up the the volume control by double clicking on the volume icon, then edit the preferences, try enabling the various "audio tracks" one by one, some of them actually provide switches rather than volume controls for different outputs. On my hardware (apple macbook and an nforce 2 box) enabling one of those provided a tick box for 2 channel or 5.1.

    Have a look anyway if you haven't already

  5. #5
    Join Date
    Jan 2008
    Beans
    10

    Re: No surround sound

    Quote Originally Posted by issih View Post
    I'll probably offend your intelligence by suggesting this, but I'll say it anyway

    If you open up the the volume control by double clicking on the volume icon, then edit the preferences, try enabling the various "audio tracks" one by one, some of them actually provide switches rather than volume controls for different outputs. On my hardware (apple macbook and an nforce 2 box) enabling one of those provided a tick box for 2 channel or 5.1.

    Have a look anyway if you haven't already

    Nope, I've tried that a couple of times already, wish it was that simple

  6. #6
    Join Date
    Jun 2007
    Beans
    11,536

    Re: No surround sound

    Have you configured the alsa-base file?
    http://ubuntuforums.org/showpost.php...58&postcount=2

  7. #7
    Join Date
    Jan 2008
    Beans
    10

    Re: No surround sound

    Quote Originally Posted by Temüjin View Post
    Have you configured the alsa-base file?
    http://ubuntuforums.org/showpost.php...58&postcount=2
    Thanks, I tried it with "3stack-6ch" and "auto" but that didn't help either .



    EDIT: It's working now! Not sure what I did, most likely it was just rebooting after the above tip .
    Just suddently all the options were there in alsamixer!
    Last edited by TerminusEst; June 9th, 2008 at 06:23 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •