Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: No sound: Acer Aspire 6920

  1. #1
    Join Date
    Jun 2008
    Beans
    10

    No sound: Acer Aspire 6920

    Hello everyone.

    I recently got a new laptop, an Acer Aspire 6920. I installed 8.04 yesterday, only to find out that i could not get the sound running.

    I (obviously) verified that my hardware was working beforehand, so that is a non-issue.

    Code:
    asoundconf list
    Names of available sound cards:
    Intel
    Code:
    aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: Intel [HDA Intel], device 0: ALC883 Analog [ALC883 Analog]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    I made sure that nothing was muted in alsaconfig, as i have seen that was an issue in other threads.

    I have also read that quite a lot of people have trouble with this specific sound card. However, none of the fix i have seen worked so far. So, i thought i might have more luck by asking.

    Thanks!

  2. #2
    Join Date
    Jan 2008
    Beans
    4,757

    Re: No sound: Acer Aspire 6920

    Have you set all playback PulseAudio to ALSA in the Sound properties? ("System>Preferences>Sound" in the Gnome Menu).

    Do you get anything from the beep test?


    running alsamixer in the terminal will show the current volume level.
    Code:
    alsamixer
    And running this command should produce a three clicking sounds from your speakers, if they have been detected properly..
    Code:
    for i in 1 2 3; do echo >/dev/dsp1; done
    Regards
    Iain

  3. #3
    Join Date
    Jun 2008
    Beans
    10

    Re: No sound: Acer Aspire 6920

    I have made sure that every sound in alsamixer is both maxed and un-muted.

    Code:
    raphael@raphael-laptop:~$ sudo for i in 1 2 3; do echo >/dev/dsp1; done
    bash: syntax error near unexpected token `do'
    raphael@raphael-laptop:~$ for i in 1 2 3; do echo >/dev/dsp1; done
    bash: /dev/dsp1: Permission denied
    bash: /dev/dsp1: Permission denied
    bash: /dev/dsp1: Permission denied
    So no, not getting any sound, i find that quite strange to be honest.

  4. #4
    Join Date
    Jan 2008
    Beans
    4,757

    Re: No sound: Acer Aspire 6920

    Interesting...
    At first look, seems like the audio device module isn't turned on.

    This will probably prove otherwise
    Code:
    ls -ld /dev/dsp*
    If the device is shown (will be in yellow), can you post the output of this command.
    Code:
    groups
    But while you are doing that. I will look into seeing if there is a way to enable it for you.

    Regards
    Iain

  5. #5
    Join Date
    Jun 2008
    Beans
    10

    Re: No sound: Acer Aspire 6920

    Code:
    raphael@raphael-laptop:~$ ls -ld /dev/dsp*
    crw-rw----+ 1 root audio 14, 3 2008-06-06 13:32 /dev/dsp
    raphael@raphael-laptop:~$ groups
    raphael adm dialout cdrom floppy audio dip video plugdev fuse lpadmin admin pulse pulse-access pulse-rt
    the /dev/dsp part is indeed shown in yellow.

  6. #6
    Join Date
    Jan 2008
    Beans
    4,757

    Re: No sound: Acer Aspire 6920

    Ah, OK. It is there then (just wasn't under the name I was expecting).

    So the proper command to test would be
    Code:
    for i in 1 2 3; do echo >/dev/dsp; done
    then. (minus the "1").

    After looking around a bit, the only thing I can suggest at the moment is do you have your backports and ubuntu modules installed for your current kernel version?
    Code:
    sudo apt-get install linux-backports-modules-$(uname -r) linux-ubuntu-modules-$(uname -r) linux-restricted-modules-$(uname -r)
    After installing them, reboot.

    Iain

  7. #7
    Join Date
    Jun 2008
    Beans
    10

    Re: No sound: Acer Aspire 6920

    Code:
    for i in 1 2 3; do echo >/dev/dsp; done
    Works, but i do not hear any clicking, or any sound at all.

    Installed those 3 backport packages, rebooted, and still nothing.

  8. #8
    Join Date
    Jan 2008
    Beans
    4,757

    Re: No sound: Acer Aspire 6920

    OK, the best option I've found so far is here.
    Sorry about the wait. But sources are scarce.

    First, check that this file is present:
    Code:
    test -s /lib/modules/$(uname -r)/ubuntu/sound/alsa-driver/pci/hda/snd-hda-intel.ko && echo YES || echo NO
    You should get the answer "YES" on screen.

    If so, open up the alsa's modprobe config file:
    Code:
    gksu gedit /etc/modprobe.d/alsa-base
    And add this line to the bottom:
    options snd-hda-intel model=mitac
    Then the command
    Code:
    sudo rmmod snd-hda-intel
    sudo modprobe snd-hda-intel
    To restart you device. (reboot may be required, but shouldn't be necessary).

    [EDIT]
    There is also an apparently fix at launchpad
    https://bugs.launchpad.net/ubuntu/+bug/210865
    Read and follow the instructions on the last post.


    If it still isn't working, check out this post here and give OSS4 a try.
    Apparently, using OSS4's drivers work much better than ALSA's with newer soundcards.

    Also, if you do get them working, first thing I suggest before you try to test is that you turn the volumes down by half
    Just incase the sudden loud sound scares you.

    Regards
    Iain
    Last edited by ibuclaw; June 6th, 2008 at 10:51 PM.

  9. #9
    Join Date
    Jun 2008
    Beans
    10

    Re: No sound: Acer Aspire 6920

    Adding the line
    options snd-hda-intel model=mitac
    Did not work, so i went on and tried the launchpad fix. This one did not work either.

    So i'm gonna go try the OSS4 method.By the way, thank you very much for your help, it is very much appreciated.

  10. #10
    Join Date
    Jun 2008
    Beans
    10

    Re: No sound: Acer Aspire 6920

    I used the step-by-step instructions to install OSS4 found HERE.

    And guess what? it WORKED! My precious sound is working now.

    Thanks again for the help, greatly appreciated.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •