Results 1 to 6 of 6

Thread: Need help with mencoder and audio

  1. #1
    Join Date
    Jun 2005
    Location
    Burlington, NC
    Beans
    394
    Distro
    Ubuntu 10.04 Lucid Lynx

    Need help with mencoder and audio

    I have a bunch of VOB files that I ripped from a DVD to my HD of old TV shows. I want to recode them to take up less disk space, and have successfully done so using this command:
    Code:
    nice -n 19 mencoder Episode\ 6\ -\ Past\ Sim.vob -ovc xvid -oac mp3lame -xvidencopts bitrate=2000 -o xvid-2000.avi
    The problem is that it gives me the Spanish audio track instead of the English one. When I just watch the VOB file I get the audio in English, but if I recode it I get the audio in Spanish.
    Can someone tell me where I went wrong? I like the size compression - a 2G file is reduced to 680M and the quality stays as well.
    Thanks in advance!

  2. #2
    Join Date
    Sep 2006
    Beans
    24
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Need help with mencoder and audio

    I'm not sure, but maybe using the "-aid #" option, where # is the number of the audio track.
    I hope that helps.

  3. #3
    Join Date
    Dec 2006
    Beans
    7,287

    Re: Need help with mencoder and audio

    Hi:

    Quote Originally Posted by jakev383 View Post
    The problem is that it gives me the Spanish audio track instead of the English one. When I just watch the VOB file I get the audio in English, but if I recode it I get the audio in Spanish.
    You could try adding

    Code:
    -alang en
    to your encoding string. BTW you might be able to drop your bitrate a little and not notice any degradation of the image.

    Andrew.
    You think that's air you're breathing now?

  4. #4
    Join Date
    Jan 2007
    Beans
    2,052

    Re: Need help with mencoder and audio

    i recommend ogg theora for video & ogg for audio. there are programs to do specifically this in the repo.
    Linux User #440528
    openSUSE 12.1 x86_64/KDE 4.8.4

  5. #5
    Join Date
    Jun 2005
    Location
    Burlington, NC
    Beans
    394
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Need help with mencoder and audio

    Quote Originally Posted by andrew.46 View Post
    Hi:



    You could try adding

    Code:
    -alang en
    to your encoding string. BTW you might be able to drop your bitrate a little and not notice any degradation of the image.

    Andrew.

    Thanks, but the one didn't work.
    I had the bitrate at 1000 and it didn't look that hot to me. I just jumped to 2000 instead of trying something like 1500 because I was impatient. Once I get the audio thing worked out I'll play with the bitrates some. I'm trying the "-aid 1" method now. Wish me luck!

  6. #6
    Join Date
    Jun 2005
    Location
    Burlington, NC
    Beans
    394
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Need help with mencoder and audio

    This ended up working for me:
    Code:
    nice -n 19 mencoder Episode\ 6\ -\ Past\ Sim.vob -ovc xvid -oac mp3lame -aid 128 -xvidencopts bitrate=2000 -o xvid-2000.avi
    Thanks!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •