Results 1 to 2 of 2

Thread: correct apache config for virtual hosting

  1. #1
    Join Date
    May 2008
    South Wales, UK
    Ubuntu 8.04 Hardy Heron

    Exclamation correct apache config for virtual hosting

    I followed the tutorial here:

    on setting up a localhost / lamp-stack.

    I got to the point where it reports a message saying "It is working." Everything fine on that front.

    However, when I tried to restart Apache, I received the following error message, which I cannot understand:

    open: Permission denied
     * Restarting web server apache2                                                httpd (pid 6139?) not running
    (13)Permission denied: make_sock: could not bind to address
    no listening sockets available, shutting down
    Unable to open logs
    open: Permission denied
    Can anyone point me in the right direction for resolving this permission denied error?


    UPDATE: I forgot to sudo my apache restart command
    Last edited by jbc-wales; May 20th, 2008 at 03:09 PM. Reason: resolved

  2. #2
    Join Date
    May 2008

    Re: correct apache config for virtual hosting

    It looks like in your Vhosts.conf file that when you were setting up your virtual hosts you made a typo of the IP address for your default destination (or one of the other virtual hosts). Look in there first and see if anything looks out of place.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts