Results 1 to 4 of 4

Thread: dpkg error

  1. #1
    Join Date
    Feb 2008
    Location
    Cincinnati
    Beans
    53
    Distro
    Ubuntu

    dpkg error

    I tried to get GnuCash aqbanking thing to work. In the process I felt I needed to install libchipcard3. I found only am rpm package and converted it to a deb using alien. It would not install properly.

    However, I cannot remove it at all. Update manager gives me the following error:

    Package in inconsistent state

    The package 'libchipcard3' is in a inconsistent state and needs to be reinstalled, but no archive can be found for it. Please reinstall the package manually or remove it from the system.

    I tried the following and it did not work:

    natibo@natibo:~$ dpkg --force-all -r libchipcard3
    dpkg: operation requires read/write access to dpkg status area
    natibo@natibo:~$ sudo dpkg --force-all -r libchipcard3
    dpkg - warning, overriding problem because --force enabled:
    Package is in a very bad inconsistent state - you should
    reinstall it before attempting a removal.
    (Reading database ... 157165 files and directories currently installed.)
    Removing libchipcard3 ...
    test: 12: Illegal number: remove
    /var/lib/dpkg/info/libchipcard3.postrm: 15: sbin/insserv: not found
    dpkg: error processing libchipcard3 (--remove):
    subprocess post-removal script returned error exit status 127
    Processing triggers for libc6 ...
    ldconfig deferred processing now taking place
    Errors were encountered while processing:
    libchipcard3
    natibo@natibo:~$

    If I try to reinstall I get this:

    natibo@natibo:~$ dpkg -i libchipcard3_3.0.3-28_amd64.deb
    dpkg: requested operation requires superuser privilege
    natibo@natibo:~$ sudo dpkg -i libchipcard3_3.0.3-28_amd64.deb
    Selecting previously deselected package libchipcard3.
    (Reading database ... 157166 files and directories currently installed.)
    Preparing to replace libchipcard3 3.0.3-28 (using libchipcard3_3.0.3-28_amd64.deb) ...
    Unpacking replacement libchipcard3 ...
    test: 12: Illegal number: upgrade
    /var/lib/dpkg/info/libchipcard3.postrm: 15: sbin/insserv: not found
    dpkg: warning - old post-removal script returned error exit status 127
    dpkg - trying script from the new package instead ...
    test: 12: Illegal number: failed-upgrade
    /var/lib/dpkg/tmp.ci/postrm: 15: sbin/insserv: not found
    dpkg: error processing libchipcard3_3.0.3-28_amd64.deb (--install):
    subprocess new post-removal script returned error exit status 127
    test: 12: Illegal number: abort-upgrade
    /var/lib/dpkg/tmp.ci/postrm: 15: sbin/insserv: not found
    dpkg: error while cleaning up:
    subprocess post-removal script returned error exit status 127
    Processing triggers for libc6 ...
    ldconfig deferred processing now taking place
    Errors were encountered while processing:
    libchipcard3_3.0.3-28_amd64.deb
    natibo@natibo:~$
    Bo

  2. #2
    forestpixie Guest

    Re: dpkg error

    Try this to remove it

    Code:
    dpkg --remove --force-remove-reinstreq libchipcard3

  3. #3
    Join Date
    Aug 2006
    Location
    Thailand
    Beans
    1,667
    Distro
    Ubuntu 10.04 Lucid Lynx

    Talking Re: dpkg error

    This will remove the listing from the /var/lib dpkg/status file.

    1. open nautilus in super user mode. ie In a terminal type this in: gksu nautilus. It will ask you for your password.

    2. When Nautilus opens, navigate to /var/lib/dpkg/status

    3. Right click on the status file and open it in text editor.

    4. Carefully search through the listings and locate libchipcard3 and delete every reference to it.

    5. Save the file and re-start.

    6. The error should now be gone.

    7. As a precaution I would back-up the ststus file, before altering it.

    Regards,
    Roger
    There are only two things in life that are mandatory.
    Birth and Death.
    Everything else is optional.
    Ubuntu User #10495

  4. #4
    Join Date
    Nov 2007
    Location
    Central Coast, California
    Beans
    1,789

    Re: dpkg error

    As a side note, was there a source package for libchipcard3? I'd recommend compiling (especially with checkinstall) over using alien any day of the week.
    I do not use Ubuntu any more, nor have I ever used Gnome. Therefore, I tend to give advice that is distro- and DE-agnostic, which, while perhaps not the easiest way, will allow you to move freely between machines.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •