Results 1 to 1 of 1

Thread: How to disable X server autorestart after logout from Gnome

  1. #1
    Join Date
    May 2008
    Beans
    11

    How to disable X server autorestart after logout from Gnome

    Hi, everyone.
    Sometimes I need to shut down Gnome and Xserver and leave only command line for my server work. But when i'm leaving Gnome with
    Code:
    gnome-session-save --kill --silent
    or stopping X with Ctrl+Alt+Backspace combination
    it brings me to tty1, but afer a few seconds Gnome(and X) starts again with graphical Welcome screen and asking me to log in.
    So, is there any way to disable that autorestart? I'm sure when I'll need it I'll start it with
    Code:
    sudo gdm
    Thank's for your help.

    SOLVED:

    Don't use GDM. Use xinit

    In your home directory create .xinitrc file with

    gnome-session

    and use xinit from console to start Gnome. When you will logout - it won't start X automatically
    Last edited by vrybas; May 13th, 2008 at 08:34 AM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •