Results 1 to 2 of 2

Thread: Turtle Beach AudioAdvantage Micro issue

  1. #1
    Join Date
    Jun 2007
    Location
    Burlington, Ontario, CA
    Beans
    309
    Distro
    Kubuntu 11.10 Oneiric Ocelot

    Turtle Beach AudioAdvantage Micro issue

    I bought this USB sound card hoping to get digital surround on my laptop, but I can't get it working. Google just turns up a bunch of questions, some up to 3 years old, but with no answers. So, straight up, does anyone know how to get one of these USB cards working? It shows up on lsusb but not in my "Sounds" menu.

    I also tried everything in this thread to no avail: http://ubuntuforums.org/showthread.php?t=402293
    Rig: Intel Core i5 2500K [4.7GHz]; ASUS Maximus IV Gene-Z; AMD Radeon HD 6870; 16GB Geil DDR3-1600; OCz Vertex 2 128GB SSD; Lian Li PC-V351B; Corsair H100 cooler; Corsair TX650W; 3x BenQ G2222HDL + 1x Acer x93w; Ubuntu 11.10 64-bit

  2. #2
    Join Date
    Jun 2007
    Location
    Burlington, Ontario, CA
    Beans
    309
    Distro
    Kubuntu 11.10 Oneiric Ocelot

    Re: Turtle Beach AudioAdvantage Micro issue

    Tried another google search but still nothing that works. Anyone?
    Rig: Intel Core i5 2500K [4.7GHz]; ASUS Maximus IV Gene-Z; AMD Radeon HD 6870; 16GB Geil DDR3-1600; OCz Vertex 2 128GB SSD; Lian Li PC-V351B; Corsair H100 cooler; Corsair TX650W; 3x BenQ G2222HDL + 1x Acer x93w; Ubuntu 11.10 64-bit

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •