Results 1 to 2 of 2

Thread: "No screens found" in GDM

  1. #1
    Join Date
    Dec 2006
    Location
    Sofia, Bulgaria
    Beans
    31
    Distro
    Ubuntu 10.04 Lucid Lynx

    "No screens found" in GDM

    I'm using ubuntu studio, with installed generic kernel and ubuntu artwork... It's almost ubuntu, but with some studio settings.

    When i tried to install nvidia propietary driver using envy, it installs nvidia-glx-new (i have nvidia 5200)

    Driver don't appear in Hardware drivers, and i use nvidia-xconfig to enable the driver. When i try to start X, it says "no screens found" - i find myself with no graphical environment.
    What's wrong? This is my xorg.conf after running nvidia-xconfig:


    Section "ServerLayout"
    Identifier "Default Layout"
    Screen "Default Screen" 0 0
    InputDevice "Generic Keyboard" "CoreKeyboard"
    InputDevice "Configured Mouse"
    EndSection

    Section "Files"
    EndSection

    Section "Module"
    Load "glx"
    EndSection

    Section "InputDevice"
    Identifier "Generic Keyboard"
    Driver "kbd"
    Option "XkbRules" "xorg"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us,bg"
    Option "XkbVariant" ","
    Option "XkbOptions" "grp:alt_shift_toggle,lv3:ralt_switch,grp_led:scro ll"
    EndSection

    Section "InputDevice"
    Identifier "Configured Mouse"
    Driver "mouse"
    Option "CorePointer"
    EndSection

    Section "Monitor"
    Identifier "Configured Monitor"
    EndSection

    Section "Device"
    Identifier "Configured Video Device"
    Driver "nvidia"
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Device "Configured Video Device"
    Monitor "Configured Monitor"
    DefaultDepth 24
    Option "AddARGBGLXVisuals" "True"
    SubSection "Display"
    Depth 24
    Modes "nvidia-auto-select"
    EndSubSection
    EndSection

    Section "Extensions"
    Option "Composite" "Enable"
    EndSection

  2. #2
    Join Date
    Dec 2006
    Location
    Sofia, Bulgaria
    Beans
    31
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: "No screens found" in GDM

    Got it!
    In some magic way, the driver appeared in Hardware Drivers and activating from there seems to work. It happened that way in Feisty - worked from Hardware Drivers, but giving errors from running nvidia-xconfig

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •