I turned on my laptop this morning and found there were some updates, mostly for apport and evolution-data-server. During the upgrade however, the computer crashed.

Upon restart, I tried running it again, and got the error
Code:
 files list file for package `libecal1.2-7' is missing final newline
After much research I discovered fixing this was a matter of deleting /var/lib/dpkg/info/libecal1.2-7.list, purging the package, then reinstalling it. However, upon running apt-get again to purge, I get the following error
Code:
 files list file for package `libedata-book1.2-2' is missing final newline
Note I've tried adding a newline to the corresponding file, no luck, though comparing it to other .list files shows something isn't right

Code:
Package: libecal1.2-7
Status: install ok unpacked
Priority: optional
Section: libs
Installed-Size: 716
Maintainer: Ubuntu Desktop Team <ubuntu-desktop@lists.ubuntu.com>
Architecture: i386
Source: evolution-data-server
Version: 2.22.1-0ubuntu2.1
Config-Version: 2.22.1-0ubuntu2
Depen
Other .list files in the same directory have lists of files.

I've considered just removing all the troublesome .list files and purging the packages as it's been suggested, however apt-get preliminaries shows that such and action will thoroughly wreck my system by removing a vast number of packages (pretty much all of Gnome). I'd rather not do that, nor do I prefer to format and start fresh (considering I've done that twice in the last week-once to install 8.04, again to install 7.10 and then upgrade so I'd have the old kernel as the new one doesn't get along with wpa_supplicant and the eeemadwifi drivers).

Any help would be so greatly appreciated.