Results 1 to 3 of 3

Thread: Saving Network DNS Settings as Default

  1. #1
    Join Date
    Dec 2007
    Beans
    9

    Saving Network DNS Settings as Default

    I'm sharing my Mac's wireless connection via ethernet to my PC and finally got it working by adding a couple of DNS servers. I saved the settings as "Home", but when I restart or even after a few minutes I have to open Network each time and re-select "Home" (with the DNS settings) to get things going.

    Is there any way to get Network to remember that I want the Home settings when I restart? It's mildly annoying.

    I'm on a dual-boot system and Windows XP Home remembers the settings after a restart.



    (Hardy Heron 8.04)
    Last edited by johnnytucats; May 3rd, 2008 at 08:12 PM. Reason: -new observation

  2. #2
    Join Date
    Oct 2007
    Location
    Chennai, India
    Beans
    3,786
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Saving Network DNS Settings as Default

    Quote Originally Posted by johnnytucats View Post
    Is there any way to get Network to remember that I want the Home settings when I restart? It's mildly annoying.
    edit your /etc/dhcp3/dhclient.conf, and look for a line "prepend domain-name-servers ...", if there is a "#" in front of it, remove it, and add the DNS servers you want to the end of the line, separating each by a space.
    Cheers,PRShah
    Make your own: Ubuntu, Kubuntu, Xubuntu, Mythbuntu All-in-One Live DVD
    "I never make mistakes; I thought I did, once.. but I was wrong."

  3. #3
    Join Date
    Dec 2007
    Beans
    9

    Re: Saving Network DNS Settings as Default

    prshah:

    That's got it working...thanks.

    Only the first DNS I enter makes it to the Network setting, however. I tried spaces between them, semicolon, semicolon and space. Looks like you have to have a semicolon after the first one or nothing gets added.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •