Results 1 to 6 of 6

Thread: Problems with USB...

  1. #1
    Join Date
    Apr 2008
    Location
    Madison, WI
    Beans
    73
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Problems with USB...

    Okay, I have mounted my video camera (loads just like an external hard drive), my jump drives, and my external hard drive all on another linux installation on this very computer. Unfortunately I get the "Invalid mount options" error when I attempt to mount them on this installation. Here is my fstab:

    I don't believe this is right...

    Code:
    # /etc/fstab: static file system information.
    #
    #  -- This file has been automaticly generated by ntfs-config -- 
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    
    proc /proc proc defaults 0 0
    # Entry for /dev/sda2 :
    UUID=ee68d6fa-5a31-4931-a37b-2c9ead199307 / ext3 defaults,errors=remount-ro 0 1
    # Entry for /dev/ !! UNKNOW DEVICE !! :
    UUID=76b46df3-cc3a-48ca-a944-f4b341520d6b none swap sw 0 0
    /dev/sdb1 /media/cdrom0 udf,iso9660 user,noauto,exec 0 0
    /dev/hda /media/cdrom1 udf,iso9660 user,noauto,exec 0 0
    /dev/scd0 /media/cdrom2 udf,iso9660 user,noauto,exec 0 0
    none /proc/bus/usb usbfsn devgid=1001,devmode=664 0 0
    I haven't seen a whole lot of fstabs, but I'm fairly positive that this is not normal. Any ideas?

  2. #2
    Join Date
    Jul 2007
    Location
    Virginia, US
    Beans
    Hidden!

    Re: Problems with USB...

    You could try making a backup of your fstab, and commenting out the line under !!UNKNOWN DEVICE !!. You might also want to edit out the last line, just to see what happens.

    BTW how many CD drives to you have, 3?
    Registered Linux User: 453202 Registered Ubuntu User:17339
    WARNING: Don't take code or candy from strangers.

  3. #3
    Join Date
    Apr 2008
    Location
    Madison, WI
    Beans
    73
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Problems with USB...

    Actually it is a laptop with a single dvd writer. I have been curious as to why I have the extra drives showing up but I haven't had time to mess with it. Right now it is pretty much crucial that I get my jump drives to work...

  4. #4
    Join Date
    Apr 2008
    Location
    Madison, WI
    Beans
    73
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Problems with USB...

    Okay, I fixed it... I commented out these lines:

    Code:
    UUID=76b46df3-cc3a-48ca-a944-f4b341520d6b none swap sw 0 0
    /dev/sdb1 /media/cdrom0 udf,iso9660 user,noauto,exec 0 0
    /dev/scd0 /media/cdrom2 udf,iso9660 user,noauto,exec 0 0
    That removed not only the extra disc drives, but also got the jump drive to work!!! Thanks!

  5. #5
    Join Date
    Jul 2007
    Location
    Virginia, US
    Beans
    Hidden!

    Re: Problems with USB...

    Did you have them plugged in when you installed?

    From what I have seen Fstab is supposed to only handle auto-mounting your system drives during boot, for example here is mine:
    Code:
    # /etc/fstab: static file system information.
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    # /dev/sda2
    UUID=f14d0638-46bc-420e-b6c3-4a52db2e2a76 /               ext3    relatime,errors=remount-ro 0       1
    # /dev/sda3
    UUID=1be85287-8dc1-4b5a-99ec-72e9ca209910 none            swap    sw              0       0
    /dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
    //SVSPEC30/Net$ /mnt/Net smbfs credentials=/home/hetirv/.smbcredentials,uid=1000 0 0
    sda2 is my system folder
    sda3 is swap
    scd0 is my DVD burner on this laptop
    the last line is a network drive.

    Try plugging in your Jump Drive and typing
    Code:
    sudo mount -a
    this will remount all drives.
    Registered Linux User: 453202 Registered Ubuntu User:17339
    WARNING: Don't take code or candy from strangers.

  6. #6
    Join Date
    Jul 2007
    Location
    Virginia, US
    Beans
    Hidden!

    Re: Problems with USB...

    The only thing that I don't like about that working is the first line you commented was your swap file, which is where your ram overflows into, if you don't have a swap file, you computer could really slow down and not work correctly. Try uncommenting that one line.

    (I know I told you to earlier, but I didn't see the Swap in the line. My Bad)
    Registered Linux User: 453202 Registered Ubuntu User:17339
    WARNING: Don't take code or candy from strangers.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •