Yesterday I upgraded to Hardy, but when I logged in, I got the message that tells me of an error in the xkb library. Anyway, I fixed it, but now when I go to System>Preferences>Keyboard, and I click on Layout, set up my second layout (russian phonetic) and go to layout options to set ctrl+shift to change layouts.

BUT it works only for this session. When I restart the PC, it works no more. And when I go to layout options, the tick on "ctrl+shift changes group" is still there. And when I remove it and put it back, again everything starts to function properly.

Question: how can I fix it so it won't require to remove and put again that tick every time I login?

P.S. on Gutsy everything was fine