Results 1 to 10 of 10

Thread: Ubuntu hardy questions

  1. #1
    Join Date
    Jan 2005
    Beans
    39

    Ubuntu hardy questions

    I have a problem when I boot up after upgrading to Hardy from gutsy. The login screen is showing only the upper left quarter. I can still login and everything is fine afterwards.

    Also, is there a way to skip the Ubuntu start up screen with the progress bar, and instead see the text scrolling showing me what is going on? That's one of things I used to prefer about Linux over Windows; you can actually see what it was doing if it goes wrong.

  2. #2
    Join Date
    Apr 2008
    Beans
    764

    Re: Ubuntu hardy questions

    to remove the boot splash screen

    first make a backup of your menu.lst file

    Code:
     sudo cp /boot/grub/menu.lst /boot/grub/menu.lst.backup
    go into a terminal and type

    Code:
     gksudo gedit /boot/grub/menu.lst
    find the "kernel line", if more than 1, the latest kernel, and remove the words "quiet splash" off the end of the line, save and boot screen is gone.

    tell us how it goes
    sam
    Last edited by sam_delta; April 26th, 2008 at 06:56 AM. Reason: gksudo as sugested below

  3. #3
    Join Date
    Mar 2006
    Location
    New Zealand
    Beans
    603
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Ubuntu hardy questions

    I have just one addition which always need to be pointed out and that is that sudo is for command line only apps and that gksudo is preferred for GUI apps. There is an important reason why but I never remember I just apply.

  4. #4
    Join Date
    Apr 2008
    Beans
    764

    Re: Ubuntu hardy questions

    ight, thx for pointing that out frup, already edited my previous post

    heres a brief explanation on sudo vs gksudo
    http://www.psychocats.net/ubuntu/graphicalsudo

    sam
    Last edited by sam_delta; April 26th, 2008 at 06:57 AM.

  5. #5
    Join Date
    Jan 2005
    Beans
    39

    Re: Ubuntu hardy questions

    Thanks guys. I've gotten rid of the splash screen, that's a lot better.

    I still have the very large ubuntu login screen. It looks like it's 4 times bigger than my screen. Once I login I'm fine.

    Also, I'm using compiz and emerald, and any saved session windows that open up when I begin don't have window decorations. I have to close and re-open them.

  6. #6
    Join Date
    Apr 2008
    Beans
    764

    Re: Ubuntu hardy questions

    try this:

    install simple-ccsm package (compiz advanced desktop settings) then, go into system>preferences>Advanced desktop effects settings

    find the Window Decoration plug-in, you can use the top left filter to search for it.
    click on "window decoration" to enter plugin settings and search for "Command:" in that line type "emerald --replace", instead of compiz-decorator

    let us know if it works,
    sam
    Last edited by sam_delta; April 26th, 2008 at 06:52 PM.

  7. #7
    Join Date
    Jan 2005
    Beans
    39

    Re: Ubuntu hardy questions

    I should have mentioned I installed compiz-git, which would have to be removed to install simple-ccsm

  8. #8
    Join Date
    Jan 2005
    Beans
    39

    Re: Ubuntu hardy questions

    Trying to install ccsm removed compiz-git and now I'm kind of screwed. I followed the instructions at the start of this thread to reinstall it

    http://ubuntuforums.org/showthread.p...ght=compiz-git

    But I have no window decoration now, and starting compiz-git fails.

    Edit: I'm ok now, I just installed everything from the regular hardy packages and removed compiz-git.
    Last edited by justinhj; April 27th, 2008 at 03:21 AM.

  9. #9
    Join Date
    Jan 2005
    Beans
    39

    Re: Ubuntu hardy questions

    I found the window plugin you mentioned and I am using emerald --replace

  10. #10
    Join Date
    Jun 2007
    Beans
    7

    Re: Ubuntu hardy questions

    Quote Originally Posted by justinhj View Post

    I still have the very large ubuntu login screen. It looks like it's 4 times bigger than my screen. Once I login I'm fine.
    I had this same problem. It was because X was configured wrong for some reason. edit /etc/X11/xorg.conf with your editor of choice and find the "Screen" section. It will look similar to:

    Code:
    Section "Screen"
    	Identifier	"Default Screen"
    	Device		"nVidia Corporation G80 [GeForce 8600 GTS]"
    	Monitor		"Generic Monitor"
    	Defaultdepth	24
    	SubSection "Display"
    		Depth	24
    		Virtual	2048	1536
    		Modes	"1280x1024@60"	"1280x1024@50"	"1024x768@60"	"1024x768@50"
    	EndSubSection
    EndSection
    All you need to do there is comment out the "Virtual" line like so:

    Code:
    Section "Screen"
    	Identifier	"Default Screen"
    	Device		"nVidia Corporation G80 [GeForce 8600 GTS]"
    	Monitor		"Generic Monitor"
    	Defaultdepth	24
    	SubSection "Display"
    		Depth	24
    #		Virtual	2048	1536
    		Modes	"1280x1024@60"	"1280x1024@50"	"1024x768@60"	"1024x768@50"
    	EndSubSection
    EndSection
    That should fix your login problem.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •