Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: Troubleshooting the Dell Inspiron 5100 on Ubuntu

  1. #1
    Join Date
    Jan 2005
    Location
    United States
    Beans
    366
    Distro
    Ubuntu 10.04 Lucid Lynx
    Edit 2013-5-23: In case someone finds this thread I just want to add that everything works with Lubuntu 13.04 / Mörgæs.


    = = =

    Hello guys (and gals)...

    Starting a new thread troubleshooting my old Inspiron 5100 on Ubuntu, because the old one was Gutsy Gibbon (Ubuntu 7.10) specific and I wanted to make something that will be applicable to these laptops on all Ubuntu versions and not have to create a new thread every release!

    The old thread can be found here...

    NOTE: Not all information guaranteed to be accurate nor am I responsible if your laptop suddenly starts making popcorn after you try anything listed in this thread. Mmmmm...delicious popcorn.....

    From the old thread (advice may be out of date, use at own risk):

    Quote Originally Posted by bornagainpenguin View Post
    I just installed Gutsy Gibbon on my Dell Inspiron 5100. What a disappointment compared to Feisty Fawn! Whereas Feisty was able to run everything out of the box more or less on defaults (had to change a few lines in xorg.conf to improve speed) Gutsy has me stuck on VESA mode! I'm sure there have got to be other disappointed users with Inspiron 5100s, so this is a thread for all of us to tweak our way back towards usability....

    First up, slowness in booting...

    Quote Originally Posted by mahousaru View Post
    Sounds like your usplash settings are messed up.

    Check /etc/usplash.conf

    xres=1024
    yres=768

    Should match what ever your screen supports, if it doesn't then this is causing the problem and needs to be changed.

    Once you have changed it u need to update the theme with

    Code:
    sudo update-usplash-theme usplash-theme-ubuntu
    Another thing you should also do is:

    Quote Originally Posted by gaburko View Post
    Hi guys, firs post for me here.
    So, I installed Ubuntu 7.10 yesterday on a relatively OK laptop - 2 Ghz, 2 GB RAM, X1300 128 MB Video. Aaaaanyway - what immediately striked me was the slow boot.
    since I have a dual-boot (Vista) I played a little with the menu.lst - I wanted Vista to be the default. However, the change that "did it" for me was the following:

    original

    Code:
    title        Ubuntu 7.10, kernel 2.6.22-14-generic
    root        (hd0,6)
    kernel        /boot/vmlinuz-2.6.22-14-generic root=UUID=63d6696a-ee49-4735-ae70-c1fe14dfdf70 ro quiet splash
    initrd        /boot/initrd.img-2.6.22-14-generic
    quiet
    now
    Code:
    title        Ubuntu 7.10, kernel 2.6.22-14-generic
    root        (hd0,6)
    kernel        /boot/vmlinuz-2.6.22-14-generic root=UUID=63d6696a-ee49-4735-ae70-c1fe14dfdf70
    initrd        /boot/initrd.img-2.6.22-14-generic

    simply remove "ro quiet splash" and "quiet"

    dunno why, but it works - boots in about a minute -)

    Cheers
    Keep in mind moshuptrail's warning though...

    Quote Originally Posted by moshuptrail View Post
    This is great!
    BUT, a note of caution to all...
    If you get a kernel update, the updater does not copy the kernel line parameters. You will need to re-apply the vga=791 each time there is a kernel update. I don't know about the usplash.conf file. So keep a link to this post so you can look up the fix after the next kernel release!
    Personally I keep the splash and only remove the ro and quiet commands. I find it works well enough for me that way.

    Next for the video display...

    I have an ATI Radeon Mobility M7 (LW) with 32mbs of ram on it.

    I managed to wade through the various options and etc used in my old Feisty Fawn xorg.conf and find settings that worked! Compiz is amazing!!

    Code:
    # xorg.conf (xorg X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "Files"
    EndSection
    
    Section "InputDevice"
        Identifier    "Generic Keyboard"
        Driver        "kbd"
        Option        "CoreKeyboard"
        Option        "XkbRules"    "xorg"
        Option        "XkbModel"    "pc105"
        Option        "XkbLayout"    "us"
    EndSection
    
    Section "InputDevice"
        Identifier    "Configured Mouse"
        Driver        "mouse"
        Option        "CorePointer"
        Option        "Device"        "/dev/input/mice"
        Option        "Protocol"        "ImPS/2"
        Option        "ZAxisMapping"        "4 5"
        Option        "Emulate3Buttons"    "true"
    EndSection
    
    Section "InputDevice"
        Identifier    "Synaptics Touchpad"
        Driver        "synaptics"
        Option        "SendCoreEvents"    "true"
        Option        "Device"        "/dev/psaux"
        Option        "Protocol"        "auto-dev"
        Option        "HorizEdgeScroll"    "0"
    EndSection
    
    Section "InputDevice"
        Driver        "wacom"
        Identifier    "stylus"
        Option        "Device"    "/dev/input/wacom"
        Option        "Type"        "stylus"
        Option        "ForceDevice"    "ISDV4"        # Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
        Driver        "wacom"
        Identifier    "eraser"
        Option        "Device"    "/dev/input/wacom"
        Option        "Type"        "eraser"
        Option        "ForceDevice"    "ISDV4"        # Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
        Driver        "wacom"
        Identifier    "cursor"
        Option        "Device"    "/dev/input/wacom"
        Option        "Type"        "cursor"
        Option        "ForceDevice"    "ISDV4"        # Tablet PC ONLY
    EndSection
    
    Section "Device"
        Identifier    "ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500]"
        Driver        "radeon"
        BusID        "PCI:1:0:0"
        Option        "LVDSBiosNativeMode" "false"
        Option        "GARTSize" "64"
        Option        "AGPSize" "64"
        Option        "AGPMode" "4"
        Option        "XAANoOffscreenPixmaps"
        Option        "AGPMode" "8"
        Option        "AGPFastWrite" "True"
        Option        "EnablePageFlip" "true"
        Option        "EnableDepthMoves" "true"
        Option        "UseInternalAGPGART" "no"
        Option        "BackingStore" "on"
        Option        "UseInternalAGPGART" "no"
        Option        "DMAForXv" "true"
        Option        "AccelMethod" "XAA"
        Option        "ColorTiling" "on"
        Option        "AccelDFS" "true"
        Option        "TripleBuffer" "true"
        Option        "DynamicClocks" "on"
    EndSection
    
    Section "Monitor"
        Identifier    "Generic Monitor"
        Option        "DPMS"
        HorizSync    30-70
        VertRefresh    50-160
    EndSection
    
    Section "Screen"
        Identifier    "Default Screen"
        Device        "ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500]"
        Monitor        "Generic Monitor"
        DefaultDepth    24
        SubSection "Display"
            Modes        "1024x768"
        EndSubSection
    EndSection
    
    Section "ServerLayout"
        Identifier    "Default Layout"
        Screen        "Default Screen"
        Option        "AIGLX" "true"
        InputDevice    "Generic Keyboard"
        InputDevice    "Configured Mouse"
    
    # Uncomment if you have a wacom tablet
    #    InputDevice     "stylus"    "SendCoreEvents"
    #    InputDevice     "cursor"    "SendCoreEvents"
    #    InputDevice     "eraser"    "SendCoreEvents"
        InputDevice    "Synaptics Touchpad"
    EndSection
    
    Section "DRI"
        Mode    0666
    EndSection
            
    Section "Extensions"
            Option "Composite" "Enable"
    EndSection
    NOTE: The original post had the "DefaultDepth 16" I've since changed that to "DefaultDepth 24" because not running at 24 was causing me to have all sorts of issues when trying to play videos.

    Third issue, HEAT!

    Update!

    There was a thread about this in the Ubuntu-users List that suggests the issue is caused by a combination of the new desktop search "tracker" and not having i8kutils installed right...

    The "tracker" can be fixed by:

    Quote Originally Posted by Paul S
    My laptop also got real hot after I installed gutsy. I couldn't figure
    out why, but finally got gkrellm running and noticed the cpu running
    near 100% all the time. Turns out the new desktop search feature
    "tracker" was the culprit. Once I turned it off by menu System >
    Preferences > Indexing Preferences, my cpu dropped to low and the
    temperature came back to normal.
    Then for i8k (to run your fans)...

    Quote Originally Posted by toorima View Post
    I recommend installing gkrellm and the gkrellm-i8k plugin, lets you set at what temps the fans should go on and off and also gives you info about temps etc

    if you get an error with i8k you must do the following
    sudo modprobe i8k force=1
    sudo gedit /etc/modules
    add the following line to the end of the file: i8k force=1
    Fifth issue overall slowness in the system.

    I had previously recommended the zen kernel here as a solution for slowness, but unfortunately the zen kernel hasn't worked well for me in some time...if only I could go back to the earlier version that did work...alas being security-minded prevents me from doing so. I recommend Inspiron 5100 users give the Hardy Heron kernel a shot in Gutsy Gibbon. You can find more information about that here.
    Many of the issues that plagued Gutsy Gibbon are gone now in Hardy Heron (Ubuntu 8.04) and I am grateful for it! The laptop's performance seems much smoother and the processor seems to overheat less. That said there have been some negative changes and some serious regressions! The biggest one for me at the moment is the way the system handles Compiz-Fusion on my onboard ATI Radeon 7500...

    Desktop effects cannot be enabled...

    For some silly reason Ubuntu has blacklisted the working open source driver from being able to run Compiz-Fusion. This is a real downer... Fortunately there is a fix!

    Quote Originally Posted by Playa1313 View Post
    I had the same problem.

    What I did to fix it:

    Install fusion-icon (if you haven't yet

    Code:
    sudo apt-get install fusion-icon
    Run fusion-icon

    Code:
    Applications > System Tools > Compiz Fusion Icon
    Go to the tray icon and right click > Select Window Manager > Compiz

    To get this to happen every time, make fusion-icon a startup app

    Code:
    System > Preferences > Sessions > Startup Programs > Add > 
    
    Name: Fusion Icon
    Command: fusion-icon
    Comment: Starts compiz wm
    I had to manually add the emerald theme manager and advanced compiz settings manager myself in synaptics by adding the emerald and the compizconfig-settings-manager packages and their dependencies. After which, a simple restart of fusion-icon (or assuming you prefer to do it this way, logging out) will add these functions to the fusion-icon menu.

    Overheating!

    Could someone who is more familiar with the Arch Linux system please check out their power management settings on the Arch Linux wiki and convert them to instructions for use with Ubuntu? Thanks! I'll add them as soon as I get them. Could they be posted in both Fahrenheit AND Celsius please? Thanks!


    Up next...??? More will be added as I encounter issues...

    --bornagainpenguin (hoping he's been helpful)
    Last edited by mörgæs; May 23rd, 2013 at 08:15 PM. Reason: Added info for 13.04

  2. #2
    Join Date
    Nov 2007
    Beans
    1,818
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Troubleshooting the Dell Inspiron 5100 on Ubuntu

    Good restart of this thread, with even more info. Well done.

    And in case anyone wants it, here is the old thread.

  3. #3
    Join Date
    Mar 2008
    Location
    FLA
    Beans
    11
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Troubleshooting the Dell Inspiron 5100 on Ubuntu

    This was great info as i have been searching through threads for hours to get this info thanks and i use my 5100 everyday it still works great but i would like to use all the extras with it now i can again thanks alot for this post

  4. #4
    Join Date
    Mar 2008
    Location
    FLA
    Beans
    11
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Troubleshooting the Dell Inspiron 5100 on Ubuntu

    Wow i just did all the steps you posted and it killed my display and i have a heck of a time to get rid of it and back to where i could use the comp again i don't know what happned to it but something is wrong with my system and this file conf any ideas to get this working on my dell thanks for any help

  5. #5
    Join Date
    Nov 2007
    Beans
    1,818
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Troubleshooting the Dell Inspiron 5100 on Ubuntu

    Quote Originally Posted by Fordkiller View Post
    Wow i just did all the steps you posted and it killed my display and i have a heck of a time to get rid of it and back to where i could use the comp again i don't know what happned to it but something is wrong with my system and this file conf any ideas to get this working on my dell thanks for any help
    Can you get into recovery mode? If so, could you post the video card section of your xorg.conf? If you need help getting that, let us know. We're happy to help.

  6. #6
    Join Date
    Mar 2008
    Location
    FLA
    Beans
    11
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Troubleshooting the Dell Inspiron 5100 on Ubuntu

    Well i use the gnome most of the time but i had to log into to kde session and fixed it that way using the terminal but it set my display to 640 and that was after the settings in the above changes to the xorg.conf file. the way i got it fixed was to just uninstall the compiz and fusion-icon in the kde terminal. i tryed to make the changes in the conf file that i did but that did nothing. i had to just uninstall it all. this is the second time this has gone wrong for me the first time i had to reinstall 7.10.
    i will go and get the info and post back but as far as i know im using the m7 radion card with this laptop.

    now as a side note i was not getting the splash screen in start up but made the changes above to the files and now that works fine on 1024x768 and i get a full view with start up and shut down.

    thanks for any help with this im still learning and trying to get it but this one has me

  7. #7
    Join Date
    Mar 2008
    Location
    FLA
    Beans
    11
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Troubleshooting the Dell Inspiron 5100 on Ubuntu

    here is the info on my ati



    $ lspci -nn | grep VGA
    01:00.0 VGA compatible controller [0300]: ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500] [1002:4c57]

  8. #8
    Join Date
    Nov 2007
    Beans
    1,818
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Troubleshooting the Dell Inspiron 5100 on Ubuntu

    Quote Originally Posted by Fordkiller View Post
    here is the info on my ati



    $ lspci -nn | grep VGA
    01:00.0 VGA compatible controller [0300]: ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500] [1002:4c57]
    Yeah, it seems like you have the same card. Are you still having any problems after reinstall?

  9. #9
    Join Date
    Mar 2008
    Location
    FLA
    Beans
    11
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Troubleshooting the Dell Inspiron 5100 on Ubuntu

    Well at this point i have not tryed to reinstall it yet im going to read it all over again and then try it after a good read again and then i will let you know whats going on with it but again thanks for all the help with it and i will be posting back in soon about it

  10. #10
    Join Date
    Jun 2008
    Beans
    4

    Re: Troubleshooting the Dell Inspiron 5100 on Ubuntu

    First off, thank you bornagainpenguin, i've been browsing forums forever and nothing seemd to work, but then i just copy/pasted your xorg.inf (since i have the same graphics card as you) and WallA the effects work!
    But, there's one thing that is bothering me, and that is the fact that the effects when enabled, are laggy and buggy. Does anyone know if there's anyway to fix this? Perhaps its because my direct rendering doesn't work.

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •