Results 1 to 10 of 11

Thread: Error linux-image-2.6.24-16-generic

Threaded View

  1. #1
    Join Date
    May 2006
    Beans
    10

    Error linux-image-2.6.24-16-generic [SOLVED]

    After upgrading from gutsy via 'sudo update-manager -c -d' to hardy (yes, -d because it was a few hours before the oficial release, don't ask) i keep getting next error:

    Code:
    mz@gantz:~$ sudo apt-get dist-upgrade 
    [sudo] password for mz: 
    Leyendo lista de paquetes... Hecho
    Creando árbol de dependencias       
    Leyendo la información de estado... Hecho
    Calculando la actualización... Listo
    0 actualizados, 0 se instalarán, 0 para eliminar y 0 no actualizados.
    5 no instalados del todo o eliminados.
    Se utilizarán 0B de espacio de disco adicional después de desempaquetar.
    ¿Desea continuar [S/n]? s
    Configurando linux-image-2.6.24-16-generic (2.6.24-16.30) ...
    Running depmod.
    update-initramfs: Generating /boot/initrd.img-2.6.24-16-generic
    Running postinst hook script /sbin/update-grub.
    [: 25: ==: unexpected operator
    exec: 25: -a: not found
    User postinst hook script [/sbin/update-grub] exited with value 2
    dpkg: error al procesar linux-image-2.6.24-16-generic (--configure):
     el subproceso post-installation script devolvió el código de salida de error 2
    dpkg: problemas de dependencias impiden la configuración de linux-ubuntu-modules-2.6.24-16-generic:
     linux-ubuntu-modules-2.6.24-16-generic depende de linux-image-2.6.24-16-generic; sin embargo:
     El paquete `linux-image-2.6.24-16-generic' no está configurado todavía.
    dpkg: error al procesar linux-ubuntu-modules-2.6.24-16-generic (--configure):
     problemas de dependencias - se deja sin configurar
    dpkg: problemas de dependencias impiden la configuración de linux-image-generic:
     linux-image-generic depende de linux-image-2.6.24-16-generic; sin embargo:
     El paquete `linux-image-2.6.24-16-generic' no está configurado todavía.
     linux-image-generic depende de linux-ubuntu-modules-2.6.24-16-generic; sin embargo:
     El paquete `linux-ubuntu-modules-2.6.24-16-generic' no está configurado todavía.
    dpkg: error al procesar linux-image-generic (--configure):
     problemas de dependencias - se deja sin configurar
    dpkg: problemas de dependencias impiden la configuración de linux-restricted-modules-2.6.24-16-generic:
     linux-restricted-modules-2.6.24-16-generic depende de linux-image-2.6.24-16-generic; sin embargo:
     El paquete `linux-image-2.6.24-16-generic' no está configurado todavía.
    dpkg: error al procesar linux-restricted-modules-2.6.24-16-generic (--configure):
     problemas de dependencias - se deja sin configurar
    dpkg: problemas de dependencias impiden la configuración de linux-restricted-modules-generic:
     linux-restricted-modules-generic depende de linux-restricted-modules-2.6.24-16-generic; sin embargo:
     El paquete `linux-restricted-modules-2.6.24-16-generic' no está configurado todavía.
    dpkg: error al procesar linux-restricted-modules-generic (--configure):
     problemas de dependencias - se deja sin configurar
    Se encontraron errores al procesar:
     linux-image-2.6.24-16-generic
     linux-ubuntu-modules-2.6.24-16-generic
     linux-image-generic
     linux-restricted-modules-2.6.24-16-generic
     linux-restricted-modules-generic
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    mz@gantz:~$
    it would be no big deal, but this errors keeps me from instaling the restricted modules, that means no 3d and what's even worse, 800x600 res.

    anyone with the same problem? or even better... anyone with a solution??

    thanks
    Last edited by mzdsb; April 25th, 2008 at 12:29 AM. Reason: issue solved

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •