Thanks for this.

I do have a minor problem, though, and it concerns extensions. Every one I've installed so far has given me a "chrome registration" error, and yet seems to install and work just fine. Has anyone else had this problem? I did have the older version running when I first ran 1.5b2, though. Anyone think that could've been the cause? If so, is there anyway to correct it?