1.11 Debs can be found here:
http://packages.dfreer.org/pool/feis...inary-amd64/P/
http://packages.dfreer.org/pool/feis...binary-i386/P/
You'll need to tell apt-get not to upgrade to the latest version if you want to continue using 1.11 and upgrade your system.

Hmmm. When you are using compiz, are you using XGL or AIGLX? Generally, XGL will not allow you to play 3D games. I use nvidia + AIGLX + beryl + pSX 1.12 fullscreen and I haven't noticed any problems.