Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Opengl Wow fps low

  1. #1
    Join Date
    Jan 2006
    Location
    Texas
    Beans
    265
    Distro
    Ubuntu

    Opengl Wow fps low

    When I try to start wow from wine in opengl mode even the opening menu has REALLY low FPS (1-2).

    System specs:

    ATI Radeon Mobility 1100
    AMDTurion x2 1.6 proc
    1.5 gigs ram (128 go to the graphics card)

    The game loads up so much smoother with d3d than opengl which everyone says should not be the case.

    Any thoughts?

  2. #2
    Join Date
    May 2007
    Beans
    162
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Opengl Wow fps low

    Wich howto did you follow to install WoW? Did you apply the opengl registry tweak? And did you make sure it's spelled properly (Copy and pasting stuff is the best way)

    If you did all that then I'm not sure, but ATI cards have a bad reputation with Wine from what I've read.
    You don't need a reason to help people

    Ubuntu User #15665
    Linux user #450019

  3. #3
    Join Date
    Jan 2006
    Location
    Texas
    Beans
    265
    Distro
    Ubuntu

    Re: Opengl Wow fps low

    http://ubuntuforums.org/showthread.p...ld+of+warcraft

    That howto, I'm pretty sure I applied the registary change, will check when I Get home tonight.

    Will that change help the sluggish login scren?

  4. #4
    Join Date
    Mar 2007
    Beans
    Hidden!

    Re: Opengl Wow fps low

    You should start with checking if your ATI drivers are working properly in the first place.

    glxinfo | grep rendering

    You should see Direct rendering: Yes.

    After this you should move on to tweaking your config.wtf. I suggest using same resolution, color depth and refresh rate as your desktop to max out performance / stability.

  5. #5
    Join Date
    Aug 2006
    Location
    tuesday
    Beans
    6,502
    Distro
    Kubuntu Development Release

    Re: Opengl Wow fps low

    Useful info for the OP, but...

    Anyone who's ever played WoW know that colour depth set in config.wtf is ignored and reset upon starting the game.

  6. #6
    Join Date
    Mar 2007
    Beans
    Hidden!

    Re: Opengl Wow fps low

    If you have SET hwdetect "0" in config like you should NOTHING is ignored or reset.

  7. #7
    Join Date
    May 2007
    Beans
    1

    Re: Opengl Wow fps low

    Quote Originally Posted by Elvish Legion View Post
    When I try to start wow from wine in opengl mode even the opening menu has REALLY low FPS (1-2).

    System specs:

    ATI Radeon Mobility 1100
    AMDTurion x2 1.6 proc
    1.5 gigs ram (128 go to the graphics card)

    The game loads up so much smoother with d3d than opengl which everyone says should not be the case.

    Any thoughts?
    http://forums.wow-europe.com/thread....86873872&sid=1 So blizz issue.
    This happens for me too on both my machines. Some windows users have 5-10fps.
    Last edited by nenitza; May 28th, 2007 at 01:44 PM.

  8. #8
    Join Date
    Mar 2007
    Beans
    Hidden!

    Re: Opengl Wow fps low

    Ok here's why this is not the same issue as what's discussed in that thread because:

    1) All windows users run the game in d3d, and Elvish Legion said he has problems with specifically opengl. On wine and cedega, wow runs much better in opengl than d3d so there's definetly something wrong here.
    2) This is not a problem caused by the latest patch, at least no one has posted anything that indicates so.

    So I'm still waiting for the OP's response to my advice.

  9. #9
    Join Date
    Jan 2006
    Location
    Texas
    Beans
    265
    Distro
    Ubuntu

    Re: Opengl Wow fps low

    Quote Originally Posted by ShadowFlar3 View Post
    Ok here's why this is not the same issue as what's discussed in that thread because:

    1) All windows users run the game in d3d, and Elvish Legion said he has problems with specifically opengl. On wine and cedega, wow runs much better in opengl than d3d so there's definetly something wrong here.
    2) This is not a problem caused by the latest patch, at least no one has posted anything that indicates so.

    So I'm still waiting for the OP's response to my advice.
    Well making the wtf changes you suggested helped slightly, I'm not sure if this is a hardware issue or not....I think it may just be my card. I'm building a desktop here in a month or two so I guessI can deal with dual boot for a little longer

  10. #10
    Join Date
    Jan 2006
    Location
    Texas
    Beans
    265
    Distro
    Ubuntu

    Re: Opengl Wow fps low

    I just thought of something, may these issues be due to the fact I'm trying to run the game in fullscreen? Would windowed be better?

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •