Quote Originally Posted by speeves View Post
The dependencies are pretty old too... I used Debian about a year ago, and had these problems as well:

(today on Ubuntu Dapper)
me@mylaptop:~/downloads$ sudo dpkg -i ymessenger_1.0.4_1_i386.deb
Selecting previously deselected package ymessenger.
(Reading database ... 151246 files and directories currently installed.)
Unpacking ymessenger (from ymessenger_1.0.4_1_i386.deb) ...
dpkg: dependency problems prevent configuration of ymessenger:
ymessenger depends on libssl0.9.6; however:
Package libssl0.9.6 is not installed.
ymessenger depends on xlibs (>> 3.3.6); however:
Package xlibs is not installed.
dpkg: error processing ymessenger (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
ymessenger

I'm not finding libssl0.9.6 in the Ubuntu repositories anymore, but you can find it in Debian Sarge. (The Debian repositories are under extreme strain right now due to major changes in X, so please be patient).

Apparently, xlibs is being transitioned into xlibs-dev on Ubuntu. This change seems to be coming from Debian. Here is an excerpt from the package page:

"This package smooths upgrades from Debian 3.0 by depending on libice-dev, libsm-dev, libx11-dev, libxext-dev, libxi-dev, libxmu-dev, libxmuu-dev, libxpm-dev, libxrandr-dev, libxt-dev, libxtrap-dev, libxtst-dev, libxv-dev, x-dev, and xlibs-static-dev. This transitional package is only depended upon by packages that haven't yet corrected their dependencies to reflect the new library arrangement."

With the little research that I did, it appears that ymessenger on Ubuntu is really not worth the effort, and GAIM, Kopete, and friends are really the correct way to go. Besides, shouldn't we be supporting Free Software anyways...?

speeves
so does this mean that i didn't actually do anything wrong, nor is there a problem with my system???