Results 1 to 2 of 2

Thread: Suspend on Dell E1505 with ati X1400 +edgy

  1. #1
    Join Date
    Jul 2006
    Location
    CST
    Beans
    57
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Suspend on Dell E1505 with ati X1400 +edgy

    Here is what I did to get it to work, I used several post to get it to work and I haven't had suspend not work yet! Check my blog for updates:

    http://blog.justinconover.com/2007/0...-e1505-part-2/

    1.) Add the fglrx drivers doing the manual and add the following:

    http://wiki.cchtml.com/index.php/Ubu...allation_Guide

    $ sudo vi /etc/default/linux-restricted-modules-common
    Code:
    DISABLED_MODULES=”fglrx”
    2.) Add the following “return 1;” to powernowd at use_ondemand

    $ sudo vi /etc/init.d/powernowd
    Code:
    use_ondemand() {
    return 1;
    for x in /sys/devices/system/cpu/*; do
    echo -n ondemand >$x/cpufreq/scaling_governor;
    status=$?
    if [ $status != 0 ]; then
    return $status
    fi
    done
    return 0
    }
    $ sudo /etc/init.d/powernowd restart

    3.) Create 2 network scripts to restart ipw3945
    $ sudo vi /etc/acpi/suspend.d/07-networkmanager.sh
    Code:
    !/bin/sh
    
    /usr/bin/dbus-send –system \
    –dest=org.freedesktop.NetworkManager \
    –type=method_call \
    /org/freedesktop/NetworkManager \
    org.freedesktop.NetworkManager.sleep
    And

    $ sudo vi /etc/acpi/resume.d/63-networkmanager.sh
    Code:
    #!/bin/sh
    
    /usr/bin/dbus-send –system \
    –dest=org.freedesktop.NetworkManager \
    –type=method_call \
    /org/freedesktop/NetworkManager \
    org.freedesktop.NetworkManager.wake
    If the formating gets messed up, check out this post, about 7 down:
    http://www.ubuntuforums.org/showthre...945+%2Bsuspend

    4.) Add the following to acpi-support

    $ sudo vi /etc/default/acpi-support
    Code:
    MODULES_WHITELIST=”ipw3945 fglrx”
    SAVE_VBE_STATE=true
    POST_VIDEO=false
    SAVE_VIDEO_PCI_STATE=true
    USE_DPMS=tru
    # DOUBLE_CONSOLE_SWITCH=true
    5.) Change Power Management “Running on Battery” to “SUSPEND” when laptop lid is closed:
    Code:
    System > Preferences > Power Management > Running on Battery
    When laptop lid is closed;    Suspend

    That seems to be the special mojo to get suspend working.

  2. #2
    Join Date
    Dec 2007
    Location
    Orlando, FL, uSA
    Beans
    1
    Distro
    Ubuntu 8.04 Hardy Heron

    Angry Re: Suspend on Dell E1505 with ati X1400 +edgy

    Hello,
    Ubuntu 7.10 on Dell E1505 with Ati x1300

    I follow your instructions completely, but at step #2 where I need to modify "powernowd at use_ondemand" I am unable to edit the module, for some reason I am unable to type "return 1:"

    I did get this message: "E325: ATTENTION
    Found a swap file by the name "/etc/init.d/.powernowd.swp"
    owned by: root dated: Fri Dec 7 08:02:45 2007
    file name: /etc/init.d/powernowd
    modified: YES
    user name: root host name: brian-laptop
    process ID: 6135
    While opening file "/etc/init.d/powernowd"
    dated: Mon Dec 18 19:35:32 2006

    (1) Another program may be editing the same file.
    If this is the case, be careful not to end up with two
    different instances of the same file when making changes.
    Quit, or continue with caution.

    (2) An edit session for this file crashed.
    If this is the case, use ":recover" or "vim -r /etc/init.d/powernowd"
    to recover the changes (see ":help recovery").
    If you did this already, delete the swap file "/etc/init.d/.powernowd.swp"
    to avoid this message.
    "/etc/init.d/powernowd" 158 lines, 4108 characters
    Press ENTER or type command to continue

    "

    I am not sure how to edit the swap file or if this is the correct method.
    Last edited by watersprayer; December 7th, 2007 at 02:35 PM. Reason: Terminal gave a message prior to editing node

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •