Results 1 to 10 of 180

Thread: HowTo: Disable Synaptics Touchpad While Typing

Threaded View

  1. #1
    Join Date
    Jun 2005
    Location
    San Luis Obispo, CA
    Beans
    31
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    HowTo: Disable Synaptics Touchpad While Typing

    This Tutorial is outdated for Intrepid (8.10) and later: see https://help.ubuntu.com/community/SynapticsTouchpad

    Purpose: For many of us, our laptop touchpads get in the way of our typing quite often and can actually cause us to highlight or minimize things we didn't intend. So, this will help to alleviate that by making a small delay in the response of the touchpad after typing.

    NOTE: Please read this guide entirely before attempting to do it. There is a section where you must restart X and thus close down your internet browser. The best way to do this would be to print this guide! I hope this works as well for you as it has for me!

    Procedure:
    1. Turn on SHMCONFIG
    A. Open a Terminal. Applications -> Accessories -> Terminal

    B. Type sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf_synbackup
    C. Type gksudo gedit /etc/X11/xorg.conf Enter your password if it prompts you.

    Note: The second command in the picture is typed wrong. Please see C.

    D. Search for a section that looks like this:
    Section "InputDevice"
    Identifier "Synaptics Touchpad"
    ...
    End Section
    E. Add a line above the End Section line and put this into it:
    Option "SHMConfig" "on"

    F. Save the file and close gedit and the terminal window
    G. Write these commands down just in case this screws up your window system: sudo cp /etc/X11/xorg.conf_synbackup /etc/X11/xorg.conf and sudo killall gdm and sudo gdm
    H. This next step will restart your window system, so save any work and close any open applications. Press: Ctrl-Alt-Backspace. This should take you back to your login screen. If it does not, press Ctrl-Alt-F1 and login at the terminal window. After logging in, type the commands that you wrote down from step F in order hitting return after each command.
    I. If your login screen came up
    the first time, continue on to part 2, if not, look over waht you did carefully and see if you can spot any mistakes.

    2. Add the Startup Command

    A. Open the sessions manager: System -> Preferences -> Sessions
    B. Click the far right tab labeled Startup Programs
    C. Click the Add button
    D. Type in the following: syndaemon -i 1 -d

    E. Hit ok then hit close

    Congratualations, you are done! Note that this will not take effect until Gnome is restarted or you type the command from 2D in a terminal window. You can restart Gnome with the Ctrl-Alt-Backspace trick (make sure to save everything first!) or you can open a terminal by going to Applications -> Accessories -> Terminal.

    If you have any questions, comments, or concerns, feel free to contact me through this board, or more easily through email or AIM.

    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	terminal.png 
Views:	8971 
Size:	25.4 KB 
ID:	16863   Click image for larger version. 

Name:	xorg-conf.png 
Views:	9145 
Size:	50.7 KB 
ID:	16864   Click image for larger version. 

Name:	startup script.png 
Views:	9164 
Size:	39.4 KB 
ID:	16865  
    Last edited by ugm6hr; June 7th, 2009 at 07:55 AM. Reason: Outdated tip
    My HowTo Guides:
    Keep your touchpad from interrupting your typing: here.
    Nice, colored, text based boot and console: here.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •