Quote Originally Posted by Robor View Post
It is this exact error:

[i](gnome-panel:5100): Gtk-CRITICAL **: gtk_widget_set_sensitive: assertion 'GTI_IS_WIDGET (widget)' failed
Ah, maybe you have the "menu bar" applet turned on in gnome-panel?

You need to find the script where gnome-panel is launched, and set environment variable GTK_MENUBAR_NO_MAC=1. Or you could start gnome by a manual ~/.xinitrc:
/usr/libexec/gnome-settings-daemon &
nautilus &
metacity &
GTK_MENUBAR_NO_MAC=1 exec gnome-panel
Remove the "menu bar" plugin, then remove the "GTK_MENUBAR_NO_MAC=1", and restart gnome.

(if you start gnome-panel with GTK_MENUBAR_NO_MAC=1, all apps launched from the panel wouldn't show the mac menubar)