Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: USB ports not working

  1. #1
    Join Date
    Apr 2014
    Beans
    16

    USB ports not working

    im booting Ubuntu 12.04 from my usb stick n everything was working great but then eventually the other 2 usb ports stopped responding when i plugged something in, yesterday both worked until i restarted ubuntu now its the same, i know nothings wrong with the ports cause i can plug my usb stick that has ubuntu into one of the other 2 turn on my laptop n it boots up fine but the other 2 usb ports that arent being used arent working even if i have something plugged in them before turning my laptop on, any ideas?

  2. #2
    Join Date
    Sep 2013
    Location
    Newcastle NE (England)
    Beans
    202
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: USB ports not working

    Try the following commands to see what output you get. gksudo lshw | less and lsusb with at least 1 usb device connected.
    The mind is the greatest weapon only the strong will prosper.

  3. #3
    Join Date
    Apr 2014
    Beans
    16

    Re: USB ports not working

    Quote Originally Posted by david98 View Post
    Try the following commands to see what output you get. gksudo lshw | less and lsusb with at least 1 usb device connected.
    only shows the 1 connected with Ubuntu on it, shows nothin for the other one i had connected

  4. #4
    Join Date
    Oct 2009
    Location
    Reykjavík, Ísland
    Beans
    10,628
    Distro
    Lubuntu 15.04 Vivid Vervet

    Re: USB ports not working

    How does a live boot of 14.04 work?
    About problems due to upgrading
    Bringing old hardware back to life.
    Please visit Quick Links -> Unanswered Posts

  5. #5
    Join Date
    Nov 2008
    Location
    Storybrooke
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: USB ports not working

    Moved to Absolute Beginners Section
    Ubuntu Forums Moderation Staff
    Don't waste your energy trying to change opinions ... Do your thing, and don't care if they like it.

  6. #6
    Join Date
    Apr 2014
    Beans
    16

    Re: USB ports not working

    Quote Originally Posted by mörgæs View Post
    How does a live boot of 14.04 work?
    r u asking if the usb ports work in 14.04? i tried n no they're still refusing to work for some reason, by some miracle a few days ago they worked, then i restart n nothing

  7. #7
    Join Date
    Oct 2007
    Beans
    1,813

    Re: USB ports not working

    Try disabling the usb2 module:

    Code:
    sudo rmmod ehci-hcd
    Then, plug your usb in, count to 15, and do:

    Code:
    dmesg | tail
    and post the output

  8. #8
    Join Date
    Apr 2014
    Beans
    16

    Re: USB ports not working

    Quote Originally Posted by llamabr View Post
    Try disabling the usb2 module:

    Code:
    sudo rmmod ehci-hcd
    Then, plug your usb in, count to 15, and do:

    Code:
    dmesg | tail
    and post the output
    for the sudo rmmod ehci-hcd it said "ERROR: Module ehci_hcd does not exist in /proc/modules"

  9. #9
    Join Date
    Apr 2014
    Beans
    12

    Re: USB ports not working

    @llamabr: You cannot disable the USB modules when using the latest kernels, because they are now built-in.

  10. #10
    Join Date
    Oct 2007
    Beans
    1,813

    Re: USB ports not working

    Quote Originally Posted by geral-k View Post
    @llamabr: You cannot disable the USB modules when using the latest kernels, because they are now built-in.
    Thanks, Ubuntu, for dumbing down something I love a little bit more.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •