Results 1 to 10 of 2026

Thread: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

Threaded View

  1. #11
    Join Date
    Apr 2006
    Beans
    1,252

    Re: HOWTO: NTFS with read/write support using ntfs-3g (easy method)

    @Poka64 & Domino :

    EDIT : Scroll down to post 137 to see our last improvement

    Ok guys, here it is .
    I finaly manage to mount my NTFS partition with pmount (using /etc/allow.pmount) so i could test it a bit. And as far as i go, it works.
    What changed :
    - For the non empty directory problem, i add the option nonempty. This is safe because pmount already test if the directory is empty or not. But i really don't no why fuse see it as non empty
    - I manage to set the locale correctly. I pass lot of time on it, because i first didn't know how to get the entire locale (en_US.UTF8 instead of UTF8 ) but google is definitly my fiend 8)
    - I made 2 packages :
    * The first one, givre3.deb force all ntfs partition to use ntfs-3g instead, and to use ntfs, you have to set '-t ntfs-old' to pmount. This way, when you plug an NTFS device, gnome-volume-manager will use ntfs-3g directly and mount it with full w/r access automaticly. This has to be test (see below)
    * The second one, givre4.deb don't force ntfs-3g, so you will have to mount it manually to use ntfs-3g. This will permit to make a nautilus script to mount it with w/r access (not done already)
    - pmount didn't allow to unmount other things than device block. I made an exception to /dev/fuse, cause it's the only way to unmount it.
    So be carefull, to unmount one, you will have to unmount all. With the nautilus script, we will be able to remount the other partition.

    But it still needs some test:
    TEST for *givre3.deb:
    - Before installing the package, Plug your device and unmount it (with pumount). Be sure of that by checking /etc/mtab.
    - Install the package (*givre3.deb).
    - Test if it mount correctly without option:
    Code:
    pmount -d /dev/sd*
    it should stop for ntfs-3g (i remove the output 'filesystem:*' but you still can see the driver use). Note the option pass to mount. You should have the option locale='*.UTF8'
    - unmount it:
    Code:
    pumount /dev/fuse
    - try to mount it with the old driver
    Code:
    pmount -d -t ntfs-old /dev/sd*
    - unmount it again
    Code:
    pumount /dev/sd*
    If all work, let's try gnome-volume-manager:
    - unplug your device.
    - start gnome-volume-manager in debug mode
    Code:
    killall gnome-volume-manager
    gnome-volume-manager -d no
    - plug your device. see if it mount it correctly, and when it's done, check in /etc/mtab that the driver has been mount with fuse. Check that you have write access
    - If it's work. Great

    TEST for *givre4.deb:
    - install the package
    - plug and unmount everything
    - try to mount it without any option
    Code:
    pmount -d /dev/sd*
    - unmount it
    Code:
    pumount /dev/fuse
    - try to mount it with the ntfs driver
    Code:
    pmount -d -t ntfs /dev/sd*
    - If it works we are ready for a nautilus sript.

    Say me what option do you prefer.

    @all_other: sorry, i don't have time for the moment, i'll see that after
    Attached Files Attached Files
    Last edited by givré; July 23rd, 2006 at 10:55 PM.
    WARNING : Post with explicit contents
    Join to "STOP monolithic all-in-one unmanageable application"
    The wiki is your friend https://help.ubuntu.com/community/

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •