Results 1 to 7 of 7

Thread: 12.04 Bootup issues.

  1. #1
    Join Date
    May 2013
    Beans
    4

    12.04 Bootup issues.

    I'm having some issues with the boot speed on my Ubuntu 12.04 LTS laptop. It seems like the hard disk takes forever to mount. I am running Ubuntu on a 5400RPM hard disk, however I don't think it should be running this slow, otherwise I might consider a new hard disk or perhaps a solid-state drive.

    - Windows 7 is booting faster than Ubuntu (That really hurts my confidence).


    I have logged two sections in dmesg where it seems to be time consuming:


    [ 3.776769] EXT4-fs (sda6): recovery complete [ 3.787553] EXT4-fs (sda6): mounted filesystem with ordered data mode. Opts: (null) [ 39.364978] Adding 6066172k swap on /dev/sda5. Priority:-1 extents:1 across:6066172k [ 39.368880] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready [ 39.391646] udevd[352]: starting version 175`

    [ 49.631654] audit_printk_skb: 37 callbacks suppressed [ 49.631659] type=1400 audit(1368533401.600:24): apparmor="DENIED" operation="capable" parent=1 profile="/usr/sbin/cupsd" pid=1041 comm="cupsd" pid=1041 comm="cupsd" capability=36 capname="block_suspend" [ 63.368554] cfg80211: Found new beacon on frequency: 2467 MHz (Ch 12) on phy0


    If anyone are able to give me any support that would be much appreciated.

    Best Regards.
    Last edited by codemaniac; May 14th, 2013 at 01:57 PM. Reason: removed formatting

  2. #2
    Join Date
    Mar 2010
    Location
    Metro-ATL
    Beans
    Hidden!
    Distro
    Lubuntu 12.04 Precise Pangolin

    Re: 12.04 Bootup issues.

    Dual boot or Wubi install?

    A failing disk controller, failing sectors of a HDD or slow DHCP network response could be causing this issue. If you completely unplug the network and it is faster, that would point to the slow network as the issue.

    If it is slow on Wubi, was the Windows HDD partition defragmented before the install?

  3. #3
    Join Date
    May 2013
    Beans
    4

    Re: 12.04 Bootup issues.

    Quote Originally Posted by TheFu View Post
    Dual boot or Wubi install?

    A failing disk controller, failing sectors of a HDD or slow DHCP network response could be causing this issue. If you completely unplug the network and it is faster, that would point to the slow network as the issue.

    If it is slow on Wubi, was the Windows HDD partition defragmented before the install?
    This is a live install, tryed wubi, didnt like it.

    - Can you plz define to "unplug the network"? - since that kinda sounds like im not able to connect to the internet afterwards. and it kinda seems like that the HDD is the biggest bottleneck, but i dont know if mounting partitions normally takes 30 seconds?

    Thx
    Last edited by raghh; May 14th, 2013 at 05:31 PM.

  4. #4
    Join Date
    Mar 2010
    Location
    Metro-ATL
    Beans
    Hidden!
    Distro
    Lubuntu 12.04 Precise Pangolin

    Re: 12.04 Bootup issues.

    Disconnecting from the network is a troubleshooting technique. It will determine if networking or the HDD is the root cause.
    Later, you can plug it back in - AFTER the determination is made. You don't even need to reboot to bring the network up, just plug the cable back in.

    How did you boot a liveCD on a HDD? I'm curious.

    Mounting partitions can take milliseconds or hours. It depends on the state of the partition, whether the disk was closed cleanly before, encryption, and if there are any hardware problems. I routinely see my /home take some time to mount on an encrypted partition during boot. It is just a timing issue for the decryption software to startup - nothing more. A message asking if I'd like to wait or manually try to solve the problem is displayed every time. I wait about 10-20 seconds longer, then the boot process continues. That is on a slow netbook-class machine. I don't use that encryption on other devices, so I can't compare.

    What do the log files show related to the HDD mount at boot? The recovery complete message in your OP tells me there was something wrong with the shutdown and the volume saw this, decided an fsck was needed and did it. I might be wrong. Do you recall seeing any fsck checks during boot? Have you tried to manually force an fsck using a live-boot CD?

  5. #5
    Join Date
    May 2013
    Beans
    4

    Re: 12.04 Bootup issues.

    Quote Originally Posted by TheFu View Post
    Disconnecting from the network is a troubleshooting technique. It will determine if networking or the HDD is the root cause.
    Later, you can plug it back in - AFTER the determination is made. You don't even need to reboot to bring the network up, just plug the cable back in.

    How did you boot a liveCD on a HDD? I'm curious.

    Mounting partitions can take milliseconds or hours. It depends on the state of the partition, whether the disk was closed cleanly before, encryption, and if there are any hardware problems. I routinely see my /home take some time to mount on an encrypted partition during boot. It is just a timing issue for the decryption software to startup - nothing more. A message asking if I'd like to wait or manually try to solve the problem is displayed every time. I wait about 10-20 seconds longer, then the boot process continues. That is on a slow netbook-class machine. I don't use that encryption on other devices, so I can't compare.

    What do the log files show related to the HDD mount at boot? The recovery complete message in your OP tells me there was something wrong with the shutdown and the volume saw this, decided an fsck was needed and did it. I might be wrong. Do you recall seeing any fsck checks during boot? Have you tried to manually force an fsck using a live-boot CD?
    Hey again,

    This is a laptop so i dont use a cable to acces the internet, so this shouldnt be the case i guess?? or should go and disable it in Ubuntu?

    - I am using "sudo poweroff" to shutdown my computer, is this an 'incorrect' way of shutting it down?

    I will check the logs and run this fsck thing from a live CD.

    Edit: Well, then let me correct my self, this is a full install the old fashioned way. no wubi, no vbox no nothing. just Ubuntu .
    Last edited by raghh; May 15th, 2013 at 03:38 PM.

  6. #6
    Join Date
    Mar 2010
    Location
    Metro-ATL
    Beans
    Hidden!
    Distro
    Lubuntu 12.04 Precise Pangolin

    Re: 12.04 Bootup issues.

    Quote Originally Posted by raghh View Post
    Hey again,

    This is a laptop so i dont use a cable to acces the internet, so this shouldnt be the case i guess?? or should go and disable it in Ubuntu?

    - I am using "sudo poweroff" to shutdown my computer, is this an 'incorrect' way of shutting it down?

    I will check the logs and run this fsck thing from a live CD.

    Edit: Well, then let me correct my self, this is a full install the old fashioned way. no wubi, no vbox no nothing. just Ubuntu .
    Wifi is the worst. That could definitely delay your connection. Disable it ... just like you would unplug an ethernet cable - probably in the BIOS or with a Fn-toggle. Again, this is just for troubleshooting. Process of elimination.

    I've never used "poweroff" - what does the man page say? man poweroff
    fsck is a command you should get used to seeing. It is like chkdsk from DOS, but better at finding logical errors. However, it can only be run on an unused disk - one that is not mounted - hence why we need to boot off a liveCD to run it against the primary partition with the OS. Alternatively, you can "sudo touch /forcefsck" on the system and at the next boot, it will be run. There is always a few different ways to accomplish the same thing on Linux/UNIX.

  7. #7
    Join Date
    May 2013
    Beans
    4

    Re: 12.04 Bootup issues.

    Quote Originally Posted by TheFu View Post
    Wifi is the worst. That could definitely delay your connection. Disable it ... just like you would unplug an ethernet cable - probably in the BIOS or with a Fn-toggle. Again, this is just for troubleshooting. Process of elimination.

    I've never used "poweroff" - what does the man page say? man poweroff
    fsck is a command you should get used to seeing. It is like chkdsk from DOS, but better at finding logical errors. However, it can only be run on an unused disk - one that is not mounted - hence why we need to boot off a liveCD to run it against the primary partition with the OS. Alternatively, you can "sudo touch /forcefsck" on the system and at the next boot, it will be run. There is always a few different ways to accomplish the same thing on Linux/UNIX.
    Hey, sorry for the late answer .

    - Noneof the above solved my problem .

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •