Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: Do all the existing shell extensions in Gnome 3.6 work in 3.8?

  1. #1
    Join Date
    Nov 2008
    Location
    Whakatane, NZ
    Beans
    634
    Distro
    Ubuntu

    Do all the existing shell extensions in Gnome 3.6 work in 3.8?

    I'm thinking about testing Gnome 3.8, but before I do, do all the existing shell extensions in 3.6 work in 3.8 as well, or do they all pretty much require upgrading?

    Cheers.
    Windows free since '09 - never looked back!

  2. #2
    Join Date
    Aug 2010
    Location
    Arizona USA
    Beans
    2,853
    Distro
    Ubuntu Development Release

    Re: Q about Gnome 3.8...

    Short answer is "No".

    Some work, some don't. Some are flagged as requiring upgrading. And, there are some new extensions.

    It's all over the place...
    Intel ® P4 Extreme Edition 3.4 (Gallatin) || DFI ® LanParty PRO875B rev B1
    Crucial ® Ballistix Tracer PC4000 1GB || Mountain Mods U2-UFO Opti-1203
    XFX 7600GT 560M AGP (PV-T73A-UDF3) || Corsair HX520W Modular PSU

  3. #3
    Join Date
    Nov 2008
    Location
    Whakatane, NZ
    Beans
    634
    Distro
    Ubuntu

    Re: Q about Gnome 3.8...

    Thanks VinDSL,

    So is there somewhere that I can check which extensions work, which don't and what the new ones are before upgrading?
    Windows free since '09 - never looked back!

  4. #4
    Join Date
    Aug 2010
    Location
    Arizona USA
    Beans
    2,853
    Distro
    Ubuntu Development Release

    Re: Q about Gnome 3.8...

    Quote Originally Posted by Baldrick_NZ View Post
    Thanks VinDSL,

    So is there somewhere that I can check which extensions work, which don't and what the new ones are before upgrading?
    You're welcome.

    I don't know of any place(s) to check which extensions work, or not.
    Intel ® P4 Extreme Edition 3.4 (Gallatin) || DFI ® LanParty PRO875B rev B1
    Crucial ® Ballistix Tracer PC4000 1GB || Mountain Mods U2-UFO Opti-1203
    XFX 7600GT 560M AGP (PV-T73A-UDF3) || Corsair HX520W Modular PSU

  5. #5
    Join Date
    Nov 2008
    Location
    Whakatane, NZ
    Beans
    634
    Distro
    Ubuntu

    Re: Q about Gnome 3.8...

    Is it easily removed, if it doesn't work well for me, by purging the ppa and reverting to gnome 3.6?
    Windows free since '09 - never looked back!

  6. #6
    Join Date
    Aug 2010
    Location
    Arizona USA
    Beans
    2,853
    Distro
    Ubuntu Development Release

    Re: Q about Gnome 3.8...

    Quote Originally Posted by Baldrick_NZ View Post
    Is it easily removed, if it doesn't work well for me, by purging the ppa and reverting to gnome 3.6?
    You should be able to purge it, using ppa-purge, but no guarantees. Cavsfan had ppa-purge fail, if I remember correctly.

    Just make sure you know how to use ppa-purge before upgrading, and you should be able to downgrade to 3.6.

    If you have a problem remembering which ppa you used to install Gnome 3.8, you can try...

    Code:
    history | grep add-apt-repository
    Intel ® P4 Extreme Edition 3.4 (Gallatin) || DFI ® LanParty PRO875B rev B1
    Crucial ® Ballistix Tracer PC4000 1GB || Mountain Mods U2-UFO Opti-1203
    XFX 7600GT 560M AGP (PV-T73A-UDF3) || Corsair HX520W Modular PSU

  7. #7
    Join Date
    Nov 2008
    Location
    Whakatane, NZ
    Beans
    634
    Distro
    Ubuntu

    Re: Q about Gnome 3.8...

    Thanks again.

    I think the answer has already been decided for me. I went to upgrade using synaptic, and it told me it could only download some of the files and would I like to continue? The answer, naturally, was no.

    I might wait until the official release, which is the end of the month, if I'm not mistaken?

    Cheers.
    Windows free since '09 - never looked back!

  8. #8
    Join Date
    Aug 2009
    Beans
    881
    Distro
    Ubuntu Development Release

    Re: Q about Gnome 3.8...

    Quote Originally Posted by Baldrick_NZ View Post
    So is there somewhere that I can check which extensions work, which don't and what the new ones are before upgrading?
    Except for the extensions included in the gnome-shell-extensions package, it doesn't look good yet.

    https://extensions.gnome.org/#shell_version=3.7.91 (Next week we'll see 3.7.92 too). It'll begin to look quite a bit better once 3.8 is released.

    If you change that URL to 3.7.90, there's several more choices but it's a bit more complicated to install since the version won't match what you'll have installed.

  9. #9
    Join Date
    Mar 2006
    Location
    Williams Lake
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Q about Gnome 3.8...

    Quote Originally Posted by VinDSL View Post
    You should be able to purge it, using ppa-purge, but no guarantees. Cavsfan had ppa-purge fail, if I remember correctly.

    Just make sure you know how to use ppa-purge before upgrading, and you should be able to downgrade to 3.6.

    If you have a problem remembering which ppa you used to install Gnome 3.8, you can try...

    Code:
    history | grep add-apt-repository
    Thanks, seeing as my Ubuntu Gnome install is totally broken with the ppas added, that's a great way to check the exact names of them before running ppa-purge.

  10. #10
    Join Date
    Aug 2012
    Beans
    242
    Distro
    Ubuntu Development Release

    Re: Q about Gnome 3.8...

    Quote Originally Posted by Baldrick_NZ View Post
    Is it easily removed, if it doesn't work well for me, by purging the ppa and reverting to gnome 3.6?
    Code:
    ~❯ history | grep add-apt-repository
    ~❯ sudo add-apt-repository -r ppa:gnome3-team/gnome3
    ~❯ sudo apt-get update
    Also you can check 3rd party ppa that you've added:

    Code:
    ~❯ cat /etc/apt/sources.list.d/*
    Last edited by serdotlinecho; March 17th, 2013 at 01:12 PM.

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •