Results 1 to 9 of 9

Thread: xfce-panel, autostart.sh, anything?

  1. #1
    Join Date
    Jan 2010
    Beans
    261
    Distro
    Ubuntu 12.04 Precise Pangolin

    xfce-panel, autostart.sh, anything?

    So, earlier today I replied to a thread I started a couple days ago about AWN... and since I've been told it's dead and such - switched to Cairo like a boss which works about a thousand times better anyway and fixed three specific annoyances I had to manually fix with AWN at every restart anyway. Plus, it's more customizable and looks good. Reason number one though - the woman half of the house likes it and approves of the setup I gave her.

    Except for one thing - the top panel.

    I do not need it, everything is in Cairo and it autostarts and works excellent exactly like I needed it to. I thought as well that I knew how to remove the top panel. Turns out, not so much anymore. The old ways are not working. It's been a while for xubuntu, granted, but I'm on 12.04 and I haven't tried it since Lucid. I can disable it every time I boot up - but I cannot find an autostart.sh or any reference to xfce-panel in a script I can just comment out.

    The system doesn't need it, nothing uses it and I have everything removed from it anyway and it just autohides all empty and lonely - it wants to die as it is. It's all a minor issue, but very annoying that I just can't find this thing anywhere.

    Do I have to modify a script to kill it at every restart of xfce or can I comment it out of anything so it's gone forever?
    When your entire life is measured in one moment, you change the concept of time.

  2. #2
    Join Date
    May 2011
    Beans
    29

    Re: xfce-panel, autostart.sh, anything?

    If you drop to a terminal and sudo nano /etc/xdg/xfce4/xinitrc and search <ctl>-w panel <enter> for $panel .... it'll be around line 169ish and tabbed in a bit. Just put a # in front of it and save the file <ctl>-o <enter> and exit <ctl>-x <enter>

    That should stop it from loading in the first place.

    Scott

  3. #3
    Join Date
    Jan 2010
    Beans
    261
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: xfce-panel, autostart.sh, anything?

    Just tried it, commented out every instance of $panel and anything else relating to xfce-panel, but rebooted and still it persists. I was searching in the xdg and any conf files I could find in there too! Both in /.config and /etc.

    Maybe I'll have to add a killall xfce-panel to that? Seems kind of redundant or circular...

    If nothing else she can just deal with it
    When your entire life is measured in one moment, you change the concept of time.

  4. #4
    Join Date
    Jan 2010
    Beans
    261
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: xfce-panel, autostart.sh, anything?

    oh... let me correct myself.

    I'm looking for xfce4-panel. I've been looking for both, but no luck yet. xfce4-panel is the target. I don't want to uninstall either or remove the package, laptop might blow up or send me back in time with guns or fire or food...
    When your entire life is measured in one moment, you change the concept of time.

  5. #5
    Join Date
    Oct 2011
    Location
    ZZ9 Plural Z Alpha
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: xfce-panel, autostart.sh, anything?

    There may be some useful information here.

  6. #6
    Join Date
    Oct 2008
    Location
    Ottawa, Canada
    Beans
    805
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: xfce-panel, autostart.sh, anything?

    The most straightforward way of preventing a program from executing is to remove its execute permissions
    Code:
     sudo chmod -x /usr/bin/xfce4-panel
    Works 100% of times ... until the binary gets replaced by an update, at which point you have to repeat. Or put the chmod command (without sudo) in you /etc/rc.local file.

    Cheers!
    husband@wife$ make sandwich
    Permission denied
    husband@wife$ sudo make sandwich

  7. #7
    Join Date
    Nov 2010
    Location
    Berlin, Germany
    Beans
    4,534
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: xfce-panel, autostart.sh, anything?

    Quote Originally Posted by cortman View Post
    There may be some useful information here.
    In addition to the accepted answer there, if you are using the "Xubuntu" session, as opposed to the "Xfce" one, you need to modify "/etc/xdg/xdg-xubuntu/xfce4/xfconf/xfce-perchannel-xml/xfce4-session.xml". You can either just change the entry "xfce4-panel" to an empty string, i.e. "", or change it to "cairo-dock" straight away, this way you don't even need an entry in startup applications for it.

    If you are following that outcommenting route, however, you'd need to outcomment (with "<!-- ... -->") the panel's section in both "/etc/xdg/xdg-xubuntu/xfce4/xfconf/xfce-perchannel-xml/xfce4-session.xml" and "/etc/xdg/xfce4/xfconf/xfce-perchannel-xml/xfce4-session.xml", otherwise it would just fall back to the latter.

    Obviously, I'd choose the first way, much less hassle and the additional option to run the dock of your choice directly through it.

    Regards.

  8. #8
    Join Date
    Jan 2010
    Beans
    261
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: xfce-panel, autostart.sh, anything?

    EUREKA!!!!!!!!

    After a quick "sudo leafpad /etc/xdg/xdg-xubuntu/xfce4/xfconf/xfce-perchannel-xml/xfce4-session.xml" and outcommenting that xfce4-panel suggestion, all is working 100% as planned.

    SOLVED, and thanks to all replies. Removing the executable from the binary is one thing I did, but like you said since it updates every now and then I'd have to keep doing that. It definately works for anything, but not the way I'd like. Now I know and should have thought to know that since I AM running the xubuntu-session and NOT strictly xfce, outcommenting that (and replacing it with cairo-dock) in THAT session fixes it.

    Thanks again to all. Solved. Like a boss.
    When your entire life is measured in one moment, you change the concept of time.

  9. #9
    Join Date
    Oct 2011
    Location
    ZZ9 Plural Z Alpha
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: xfce-panel, autostart.sh, anything?

    Great! Thanks for sharing your solution!
    Good luck.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •