When using Nautilus (3.4.2 in 12.04), in the file menu, there is "Open in Terminal" which opens a terminal using the currently displayed directory as the working directory. I use this feature a lot, but I don't like that it opens in gnome-terminal. I'd rather have it open in terminator, but I can't seem to find any way to change it.

Nautilus preferences has no settings for it. "System settings...details...default applications" has no entry for terminal emulators. exo-preferred-applications does have such an entry, but it seems to have no effect on Nautilus.

Where can I change this?

--chriscrutch