Results 1 to 6 of 6

Thread: Stopped network nanager trying Internet connection through /etc/network/interfaces

  1. #1
    Join Date
    Feb 2013
    Beans
    4

    Stopped network nanager trying Internet connection through /etc/network/interfaces

    Initially my internet was running through Network Manager . But i dont know, now, why its not working. I am trying to run internet by configuring /etc/network/interfaces. But its not working. Things which i have done shown below.






    ifconfig -a
    eth0 Link encap:Ethernet HWaddr 90:fb:a6:34:01:d5
    inet addr:172.16.26.209 Bcast:172.16.27.255 Mask:255.255.252.0
    inet6 addr: fe80::92fb:a6ff:fe34:1d5/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:448 errors:0 dropped:0 overruns:0 frame:0
    TX packets:83 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:31251 (31.2 KB) TX bytes:10731 (10.7 KB)
    Interrupt:20 Base address:0x2c00

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:1 errors:0 dropped:0 overruns:0 frame:0
    TX packets:1 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:79 (79.0 B) TX bytes:79 (79.0 B)

    cat /etc/network/interfaces
    auto lo
    iface lo inet loopback

    auto eth0
    iface eth0 inet static
    address 172.16.26.209
    netmask 255.255.252.0
    gateway 172.16.24.254
    dns-nameservers 202.141.80.9

    cat /etc/hosts
    127.0.0.1 localhost
    127.0.1.1 mrityunjay-A7GMX-K

    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters

    cat /etc/resolv.conf
    # Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
    # DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
    nameserver 202.141.80.9

    cat /etc/NetworkManager/NetworkManager.conf

    [main]
    plugins=ifupdown,keyfile
    dns=dnsmasq

    no-auto-default=90:FB:A6:34:015,00:00:A6:34:015,

    [ifupdown]
    managed=false


    No ddclient.conf file in my /etc directory

    When i start my computer: which runs Ubuntu 12.04LTS, then first i type these command for stopping network manager.

    /etc/init.d/network-manager stop
    /etc/init.d/networking restart

    When, i try to run my internet it does not work. If i ping my own ip then it shows. But if i ping some different ip in network then it does not work.


    If i use internet connection with same wire then it is working in window 7. its mean that wire has no problem.


    I am in college so, internet has to pass through proxy by username and password.


    Please help me in this regards.

  2. #2
    Join Date
    Aug 2011
    Location
    Berlin, Germany
    Beans
    5,255
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: Stopped network nanager trying Internet connection through /etc/network/interface

    Code:
    cat /etc/NetworkManager/NetworkManager.conf
    
    [main]
    plugins=ifupdown,keyfile
    dns=dnsmasq
    
    no-auto-default=90:FB:A6:34:015,00:00:A6:34:015,
    
    [ifupdown]
    managed=false
    Change "false" to "true", otherwise the NM can not handle the manual config. Or uninstall the NM (which I do not recommend)

  3. #3
    Join Date
    Mar 2005
    Beans
    211

    Re: Stopped network nanager trying Internet connection through /etc/network/interface

    Quote Originally Posted by praseodym View Post
    Change "false" to "true", otherwise the NM can not handle the manual config. Or uninstall the NM (which I do not recommend)
    To be a bit more explicit about it...

    You have a choice between NetworkManager and ifup. Don't try to mix the two because you will probably end up with badly configured routes.

    If you choose NetworkManager then use the Connection Editor to configure everything, not /etc/network/interfaces. (Or configure in /etc/network/interfaces and set "managed=true", as praseodym suggested, but this is probably less good.)

    If you choose ifup then disable NetworkManager somehow. Or as praseodym suggested, uninstall it.

  4. #4
    Join Date
    Feb 2013
    Beans
    4

    Re: Stopped network nanager trying Internet connection through /etc/network/interface

    I restarted my computer and then i typed below command for stopping network manager.
    /etc/init.d/network-manager stop

    My internet is being started to work.But with the same settings it was not working previously.

    I don't know how is it starts working.

    Initially I put managed=true in NetworkManager.conf. eth0 show in Network manager wired connection configuration.

    Then i made manage=false. it is not showing in network manager wired connection configuration, and net is also working fine, then i stop Network Manager. Net is working fine with /etc/network/interfaces setting.

    i understand many things.

    Thank You


  5. #5
    Join Date
    Feb 2013
    Beans
    4

    Re: Stopped network nanager trying Internet connection through /etc/network/interface

    One day net connection has gone. After that when i started my internet. It is not working. Before the incident it was working with Stopped network manager and networking through /etc/network/interfaces setting.
    Please give some help regarding /etc/network/interfaces setting
    I already described my settings in previous reply.

  6. #6
    Join Date
    Feb 2013
    Beans
    4

    Re: Stopped network nanager trying Internet connection through /etc/network/interface

    i removed network-manager.
    Now i put all necessary information /etc/network/interfaces file.
    But still my internet is not working
    But it is working in window 7. So wire has no problem.
    Initially it was working in ubuntu also with network manager.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •