Results 1 to 7 of 7

Thread: Way to exclude second wireless interface from rfkill list? (12.10 - Quantal Quetzal)

  1. #1
    Join Date
    Feb 2013
    Beans
    4

    Question Way to exclude second wireless interface from rfkill list? (12.10 - Quantal Quetzal)

    I've been working through the various threads on the subject of physical wireless switches disabling wireless interfaces for the last hour, but I've yet to find one that answers my particular issue.

    I have an Acer laptop with an inbuilt Intel wireless nic which I use for everyday connections. I also have an Alfa USB nic for pen testing and for problematic wireless links where shouting the loudest often resolves connection drops.

    In previous releases the physical wireless switch has only disabled the inbuilt nic (Which is what I want to do to save some battery life). In the latest builds the functionality has changed to disable all network interfaces. What I'd like to do is bring the former usage scenario back for my laptop and effectively exclude the Alfa interface from the rfkill list.

    Does anyone know if this is possible and / or even if this is the right approach to take with this issue?

  2. #2
    Join Date
    Aug 2005
    Location
    West of the Animas
    Beans
    20,228
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Way to exclude second wireless interface from rfkill list? (12.10 - Quantal Quetz

    Is one listed as phy0 and the other as phy1?
    Code:
    rfkill list all
    Something like:
    0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
    1: tpacpi_bluetooth_sw: Bluetooth
    Soft blocked: yes
    Hard blocked: no
    2: phy1: Wireless LAN
    Soft blocked: no
    Hard blocked: no
    Assuming the built-in is phy0, please try, instead of the wireless switch:
    Code:
    sudo rfkill block 0
    Then check:
    Code:
    rfkill list all
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  3. #3
    Join Date
    Feb 2013
    Beans
    4

    Re: Way to exclude second wireless interface from rfkill list? (12.10 - Quantal Quetz

    Thanks for replying.

    Quote Originally Posted by chili555 View Post
    Assuming the built-in is phy0, please try, instead of the wireless switch:
    Code:
    sudo rfkill block 0
    Using rfkill (sudo rfkill block 5) in this way causes the exact same result as the physical button. rfkill list outputs the following:
    Code:
    0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: yes
    1: acer-wireless: Wireless LAN
        Soft blocked: yes
        Hard blocked: no
    5: phy4: Wireless LAN
        Soft blocked: no
        Hard blocked: no
    Even if rfkill on the physical interface did work I can't see how that would help accomplishing my end goal of reimplementing the old usage model. Is there a way to specifically tailor rfkill command sets from function key input?

  4. #4
    Join Date
    Aug 2005
    Location
    West of the Animas
    Beans
    20,228
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Way to exclude second wireless interface from rfkill list? (12.10 - Quantal Quetz

    Is there a way to specifically tailor rfkill command sets from function key input?
    None that I am aware of. You might file a bug against rfkill or acer-wmi or both and see if there are better ideas. https://help.ubuntu.com/community/ReportingBugs
    Using rfkill (sudo rfkill block 5) in this way causes the exact same result as the physical button.
    I suspect the internal is 0 and the USB is 5. Didn't you want to disable the internal?

    This result suggests the internal is blocked and the USB is working. No?
    0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
    1: acer-wireless: Wireless LAN
    Soft blocked: yes
    Hard blocked: no
    5: phy4: Wireless LAN
    Soft blocked: no
    Hard blocked: no
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  5. #5
    Join Date
    Feb 2013
    Beans
    4

    Re: Way to exclude second wireless interface from rfkill list? (12.10 - Quantal Quetz

    Reviewing the network manager app it appears that disabling the onboard wifi through the physical switch also disables the wireless from the network manager perspective. So although the USB NIC isn't blocked by rfkill the entirety of wireless connectivity is disabled.

  6. #6
    Join Date
    Aug 2005
    Location
    West of the Animas
    Beans
    20,228
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Way to exclude second wireless interface from rfkill list? (12.10 - Quantal Quetz

    Quote Originally Posted by m0rd0 View Post
    Reviewing the network manager app it appears that disabling the onboard wifi through the physical switch also disables the wireless from the network manager perspective. So although the USB NIC isn't blocked by rfkill the entirety of wireless connectivity is disabled.
    Perhaps I've been misunderstood. I'm suggesting you NOT use the switch and use the terminal command instead. While we both hope there is another more elegant solution, the terminal command is the one I'm aware of today and I hope it is helpful.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  7. #7
    Join Date
    Feb 2013
    Beans
    4

    Re: Way to exclude second wireless interface from rfkill list? (12.10 - Quantal Quetz

    Quote Originally Posted by chili555 View Post
    Perhaps I've been misunderstood. I'm suggesting you NOT use the switch and use the terminal command instead.
    Nope, I'm understanding you. Issuing the terminal command results in the exact same problem where the network manager shows the wireless disabled. Even though the USB nic isn't blocked, wireless as my laptop knows it has ceased to exist.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •