Any time I try to install anything or sudo apt-get upgrade I get the following error.

Code:
installArchives() failed: 
Extracting templates from packages: 9%%
Extracting templates from packages: 19%%
Extracting templates from packages: 28%%
Extracting templates from packages: 38%%
Extracting templates from packages: 47%%
Extracting templates from packages: 57%%
Extracting templates from packages: 66%%
Extracting templates from packages: 76%%
Extracting templates from packages: 85%%
Extracting templates from packages: 95%%
Extracting templates from packages: 100%%
Preconfiguring packages ...              
Extracting templates from packages: 9%%
Extracting templates from packages: 19%%
Extracting templates from packages: 28%%
Extracting templates from packages: 38%%
Extracting templates from packages: 47%%
Extracting templates from packages: 57%%
Extracting templates from packages: 66%%
Extracting templates from packages: 76%%
Extracting templates from packages: 85%%
Extracting templates from packages: 95%%
Extracting templates from packages: 100%%
Preconfiguring packages ...

Extracting templates from packages: 9%%
Extracting templates from packages: 19%%
Extracting templates from packages: 28%%
Extracting templates from packages: 38%%
Extracting templates from packages: 47%%
Extracting templates from packages: 57%%
Extracting templates from packages: 66%%
Extracting templates from packages: 76%%
Extracting templates from packages: 85%%
Extracting templates from packages: 95%%
Extracting templates from packages: 100%%
Preconfiguring packages ...

Extracting templates from packages: 9%%
Extracting templates from packages: 19%%
Extracting templates from packages: 28%%
Extracting templates from packages: 38%%
Extracting templates from packages: 47%%
Extracting templates from packages: 57%%
Extracting templates from packages: 66%%
Extracting templates from packages: 76%%
Extracting templates from packages: 85%%
Extracting templates from packages: 95%%
Extracting templates from packages: 100%%
Preconfiguring packages ...
(Reading database ... 
(Reading database ... 5%%
(Reading database ... 10%%
(Reading database ... 15%%
(Reading database ... 20%%
(Reading database ... 25%%
(Reading database ... 30%%
(Reading database ... 35%%
(Reading database ... 40%%
(Reading database ... 45%%
(Reading database ... 50%%
(Reading database ... 55%%
(Reading database ... 60%%
(Reading database ... 65%%
(Reading database ... 70%%dpkg: unrecoverable fatal error, aborting:
 reading files list for package 'linux-image-3.2.0-29-generic-pae': Input/output error
Error in function: 
SystemError: E:Sub-process /usr/bin/dpkg returned an error code (2)
From what I've been able to gather this could be an error with my kernel. but I dont really know. Would updating my new 12.04 install to 12.10 fix this? What are my options? Any help would be appreciated, thanks.