Results 1 to 9 of 9

Thread: Pavucontrol for Audacity

  1. #1
    Join Date
    Jan 2013
    Beans
    5

    Question Pavucontrol for Audacity

    Hi everybody. I am not only new to this forum but I am totally new to Linux! And pretty new to writing commands in terminal windows! But not completely computer illiterate! I have installed Audacity in Ubuntu and now want to install Pavucontrol. I have downloaded the pkg but when I try to install it get the message: Items cannot be installed or removed until the pkg catalogue is repaired. Do you want to repair it now? I click 'Repair' but nothing happens. I just keep getting the message which appears now when I try to install other pkgs. Help??

    Elborath

  2. #2
    Join Date
    Feb 2008
    Location
    Planet earth, for now.
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: Pavucontrol for Audacity

    Welcome to the forums. You need to have Pulse Audio installed, which it should be by default. Why not just install pavucontrol from Software Centre or Synaptics? You don't need to add any repos. It's there already.

  3. #3
    Join Date
    Jan 2013
    Location
    Another Dimension
    Beans
    164
    Distro
    Kubuntu 12.10 Quantal Quetzal

    Re: Pavucontrol for Audacity

    Try repairing package installer through terminal
    Code:
    sudo apt-get install -f
    Code:
    sudo dpkg --configure -a
    Code:
    sudo apt-get update && sudo apt-get upgrade

  4. #4
    Join Date
    Jan 2013
    Beans
    5

    Re: Pavucontrol for Audacity

    Thank both Bucky and Furything. I did as you advised Fury--the repository couldn't be found (accessed or whatever) even though I had ?installed it and downloaded Audacity through it. So some info was missing--it couldn't find 'a' for example. Yes Bucky, according to Software Centre I DO have Pavucontrol installed already! Told you I was a noobie! However I can't seem to open it in order to change the settings so I can record streaming (I need to record voice in an online virtual environment).

    I still get the error message (repair needed) when I open Software centre

  5. #5
    Join Date
    Jan 2013
    Beans
    5

    Re: Pavucontrol for Audacity

    These are the details regarding the failure:

    installArchives() failed: dpkg: dependency problems prevent configuration of pavucontrol:
    libpulse0 (1:1.1-0ubuntu15.2) breaks pavucontrol (<< 0.9.8) and is installed.
    Version of pavucontrol to be configured is 0.9.5-1ubuntu1.
    dpkg: error processing pavucontrol (--configure):
    dependency problems - leaving unconfigured
    No apport report written because MaxReports is reached already
    Errors were encountered while processing:
    pavucontrol
    Error in function:
    dpkg: dependency problems prevent configuration of pavucontrol:
    libpulse0 (1:1.1-0ubuntu15.2) breaks pavucontrol (<< 0.9.8) and is installed.
    Version of pavucontrol to be configured is 0.9.5-1ubuntu1.
    dpkg: error processing pavucontrol (--configure):
    dependency problems - leaving unconfigured

  6. #6
    Join Date
    Jan 2013
    Location
    Another Dimension
    Beans
    164
    Distro
    Kubuntu 12.10 Quantal Quetzal

    Re: Pavucontrol for Audacity

    Looks a bit messy
    I think you need to clean up first by removing pavucontrol
    Code:
    sudo dpkg --force-all -P pavucontrol
    Redo previous commands from earlier post to ensure all ok

    Use the packager manager tool and install the software you want through it.

    If you don't like the default tool then tell it to install synaptic package manager and use that instead.

    You may have to tell it to use 3rd party repositories (that depends on where the software is that you want to install).

  7. #7
    Join Date
    Dec 2012
    Location
    Canada
    Beans
    187
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Pavucontrol for Audacity

    I just tried installing 'pavucontrol' from the official repositories via Synaptic Package Manager and it worked fine for me. I'm on Ubuntu 12.04 LTS and it installed

    pavucontrol 0.99.2-1build1

    I notice that your version of pavucontrol is older (0.9.5-1ubuntu1). Are you running an older version of Ubuntu?
    Last edited by GordThompson; January 28th, 2013 at 10:02 PM.

  8. #8
    Join Date
    Jan 2013
    Beans
    5

    Re: Pavucontrol for Audacity

    Thanks guys for all your help. followed your instructions to the letter Furything and it worked just great. Error messages gone and pavucontrol installed perfectly from Software Centre. I'm running 12.04 Gord. My friend who urged me to try Linux advised against 12.10 for some reason I forget.

    Very new to this but your help has been truly appreciated and I'm a quick learner. No doubt I'll be asking again--I'm thinking of installing Mint on my other laptop...
    Last edited by Elborath; January 29th, 2013 at 03:29 AM.

  9. #9
    Join Date
    Jan 2013
    Location
    Another Dimension
    Beans
    164
    Distro
    Kubuntu 12.10 Quantal Quetzal

    Re: Pavucontrol for Audacity

    Your welcome.
    Glad you are now sorted.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •