Results 1 to 4 of 4

Thread: Unity and Unity 2D missing from session selector in LightDM

  1. #1
    Join Date
    Nov 2009
    Beans
    29

    Exclamation Unity and Unity 2D missing from session selector in LightDM

    I recently installed the Cinnamon Desktop environment and after restarting noticed that the Unity and Unity 2D session options had disappeared from LightDM's session selector.
    I removed and purged all Cinnamon packages, but that didn't work. So then I reinstalled all unity-related packages to no avail either. I then removed, purged, and then reinstalled unity and unity-2d to no effect. How can this be fixed?

  2. #2
    Join Date
    Nov 2010
    Location
    Berlin, Germany
    Beans
    4,534
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: Unity and Unity 2D missing from session selector in LightDM

    First, make sure the "ubuntu-desktop" meta-package is installed:
    Code:
    sudo apt-get install ubuntu-desktop
    And if that doesn't fix it, reinstall the package "gnome-session", it includes the files providing those session options:
    Code:
    sudo apt-get install --reinstall gnome-session
    Regards.

  3. #3
    Join Date
    Nov 2009
    Beans
    29

    Re: Unity and Unity 2D missing from session selector in LightDM

    That worked for me. Thanks!

  4. #4
    Join Date
    Jan 2013
    Beans
    3

    Re: Unity and Unity 2D missing from session selector in LightDM

    Ive tried the same, and it worked for me (meaning Ubuntu is back on the cog wheel) but it only shows my desktop when it loads up, i dont get the top bar or the unity side bar just a few desktop icons

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •