I just wanted to let you know that if you are having wifi problems with a Broadcom 4331 chip (MacBook Pro 9,2 / Mid 2012) you might want to use the following options for the b43 module:

nohwcrypt=1 qos=0

(It takes a few weeks to test conclusively, so I haven't checked if individually either option is enough)

You can place them in a file like /etc/modprobe.d/b43.conf with:

options b43 nohwcrypt=1 qos=0

and then update your initramfs (update-initramfs -u).

You got them working if you see "b43-phy0 debug: QoS disabled" in your dmesg when you employ also the "verbose=3" option.