Results 1 to 6 of 6

Thread: /usr/bin/ld: cannot find -llibopencv_highgui.so

  1. #1
    Join Date
    Jan 2013
    Beans
    7

    /usr/bin/ld: cannot find -llibopencv_highgui.so RESOLVED by MadCow108 & steeldriver

    OMG i'm almost crazy , i did whatever i could but it happens again.
    my lib files are on /usr/local/lib and i insertet the path and lib files caption as u c at the image below , but as u c i get error and the build is not successful !
    Last edited by oujeboland; January 21st, 2013 at 10:09 PM.

  2. #2
    Join Date
    Jan 2013
    Beans
    1

    Re: /usr/bin/ld: cannot find -llibopencv_highgui.so

    I have the same problem like this also and i dont know what will i do next


    Cheers
    http://onlinemoderationservices.com

  3. #3
    Join Date
    Apr 2012
    Beans
    5,479

    Re: /usr/bin/ld: cannot find -llibopencv_highgui.so

    I don't know how your IDE handles these things, but by convention the '-l' expands to 'lib' i.e. to link libopencv_highgui.so you would specify that as
    -lopencv_highgui not -llibopencv_highgui.so
    Last edited by steeldriver; January 17th, 2013 at 11:14 PM.

  4. #4
    Join Date
    Jan 2013
    Beans
    7

    Re: /usr/bin/ld: cannot find -llibopencv_highgui.so

    Quote Originally Posted by steeldriver View Post
    I don't know how your IDE handles these things, but by convention the '-l' expands to 'lib' i.e. to link libopencv_highgui.so you would specify that as
    -lopencv_highgui.so not -llibopencv_highgui.so
    the lib prefix is in the main filename in the new version of the opencv , so files are named like this: libopencv_highgui.so libopencv_flann.so

  5. #5
    Join Date
    Apr 2009
    Location
    Germany
    Beans
    2,134
    Distro
    Ubuntu Development Release

    Re: /usr/bin/ld: cannot find -llibopencv_highgui.so

    all libraries on unix systems start with lib and end with .so (+ possible versioning suffixes like .so.1) or .a (static library)
    so you don't have to specify it, the compiler it will fill it in
    libopencv_highgui.so -> -lopencv_highgui
    etc.
    in your ide you probably just have to remove the lib and the .so from your settings

  6. #6
    Join Date
    Jan 2013
    Beans
    7

    Re: /usr/bin/ld: cannot find -llibopencv_highgui.so

    you both were right . i didn't understand at first.
    is there any thanks button !

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •